Problème date de naissance publipostage [Résolu/Fermé]

Signaler
-
Messages postés
4010
Date d'inscription
samedi 8 novembre 2014
Statut
Membre
Dernière intervention
3 octobre 2016
-
Bonjour,

Je gère actuellement un fichier excel de plus de 3000 personnes et j'ai régulièrement besoin de l'utiliser pour du publipostage sur word.
Tous les champs sont retransmit correctement lors du publipostage mis à part la colonne "date de naissance".
Exemples : au lieu d'afficher "25/12/1970" dans le document word, j'ai "25927", "21/04/1994" donne "34945", j'obtiens "33346" avec "18/04/1991".

Merci de votre aide

1 réponse

Messages postés
4010
Date d'inscription
samedi 8 novembre 2014
Statut
Membre
Dernière intervention
3 octobre 2016
1 605
Bonjour D90DX,

Word a converti la date en nombre de jours écoulés depuis le 01/01/1900.
Voici 3 suggestions pour récupérer les dates dans ton publipostage :

Dans ton document type Word
1. Modifie le code de champ de la date de naissance
Appuie sur [ALT] [F9] pour afficher les codes de champ. Complète le code de la date de la façon suivante avec le commutateur en gras ci-dessous (attention aux majuscules) :
{ MERGEFIELD "ton champ date" \@ "dd/MM/yyyy" }, appuie à nouveau sur [ALT] [F9] pour masquer les codes et fais un test.

2. Utilise le protocole d'échange DDE
Dans le bouton "Office" ou l'onglet [Fichier], "Options", "Options avancées" (à gauche). Dans la rubrique "Général" en bas, coche "Confirmer la conversion du format de fichier lors de l'ouverture". Refais la liaison avec ton fichier Excel.
Tu choisiras le protocole "Feuilles de calcul MS Excel via un DDE".
Cette 2e méthode impose d'avoir une seule feuille dans le classeur Excel ou qu'elle soit placée en 1re position.

Dans ta feuille Excel
3. Convertis les dates en texte dans une nouvelle colonne avec une formule du type =TEXTE(A1;"jj/mm/aaaa"). Puis tu fais un collage spécial "Valeurs" pour ne garder que le résultat, et tu utilises ce champ pour ton publipostage.

Pour quelle solution vas-tu opter ?

C-Claire
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Merci beaucoup de ton aide C-Claire, finalement mon problème a été résolu quand j'ai créé une copie de mon document word pour tester les différentes solutions que tu me proposais, j'aurais quand même bien aimé savoir se qui clochait.
Messages postés
4010
Date d'inscription
samedi 8 novembre 2014
Statut
Membre
Dernière intervention
3 octobre 2016
1 605 > D90DX
D90DX,

"j'aurais quand même bien aimé savoir se qui clochait"
moi aussi !
Mais je suis ravie que tu aies trouvé une 4e solution ;-)


C-Claire