Recherchev matricielle

Résolu/Fermé
Signaler
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
-
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
-
Bonjour,
Une petite question sur la formule rechercheV. le fichier ci jiont donne des détails.
J'ai souvent à reporter d'un fichier à l'autre des colonnes entières par recherche V, et mes variables sont, le plus souvent 0/1. Pas de valeurs uniques.
Je constate que je peux étendre ma formule rechercheV à droite et en bas, et que ça marche si les valeurs sources sont uniques.
Mais comme j'ai des 0/1, ça ne fonctionne pas.
Auriez vous une idée ? Pour éviter de faire 100 formules rechercheV pour 100 colonnes ?
http://www.cjoint.com/c/FGksmL3GFTX

merci beaucoup!

3 réponses

Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
Bon jour
on ner voit pas très bien ce que vous voulez faire entirant cette formule
Pourquoi ne pas baser votre recherche sur la valeur de A pour tout le champ et donc écrire par exemple en B2 cette formule
=RECHERCHEV($A2;'données sources'!$A:$K;COLONNE(B$1);FAUX)

à tirer sur tout le tableau
respectez bien la position des signes $ qui bloquent les références (ligne, colonne ou tout) quand vous tirer les formules

pour info
COLONNE(B1) =2 et quand vous tirez la formule vers la droite; B$2 devient C$2 =3 donc etc..

crdlmnt
1
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
95
je bosse sur ça et j'arrive; merci!
0
Messages postés
3401
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
16 janvier 2022
498
Bonjour,

Je n'ai pas bien compris ....
A tout hasard,essaye cette formule en B2

=RECHERCHEV($A2;'données sources'!$A$2:$K$31;COLONNE();FAUX)

a etirer et a descendre

Crdmt

edit :
Bonjour Vaucluse, je ne t'avais pas vu
0
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
95
je bosse sur ça et j'arrive
merci!
0
Messages postés
898
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
7 août 2018
95
merci à tous les deux, j'ai réussi! et je saurai le refaire:)
0