Somme selon date mm/aaaa uniquement

Résolu/Fermé
Richrdk Messages postés 32 Date d'inscription jeudi 10 septembre 2015 Statut Membre Dernière intervention 14 décembre 2019 - Modifié par Richrdk le 13/05/2016 à 20:56
Richrdk Messages postés 32 Date d'inscription jeudi 10 septembre 2015 Statut Membre Dernière intervention 14 décembre 2019 - 13 mai 2016 à 21:19
Bonjour à toute la communauté CCM,

ayant un tableau avec une colonne A regroupant des dates dans l'ordre chronologique (format jj/mm/aaaa) et une colonne B regroupant les coûts pour chaque date, j'aimerais calculer la somme des coûts pour chaque mois de l'année. Pour des raisons pratiques, j'aimerais extraire les caractères du mois et de l'année pour calculer les coûts mensuels dans mes formules.

Exemple :
colonne A | colonne B
07/07/2015 | 63,22€
28/07/2015 | 22,44€
11/08/2015 | 141,07€
31/08/2015 | 85,18€
15/09/2015 | 6,01€
19/09/2015 | 119,13€

Coût pour 07/2015? 08/2015? 09/2015?

Comment puis-je procéder?

En vous remerciant par avance!

A voir également:

1 réponse

Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 063
Modifié par Mike-31 le 13/05/2016 à 21:11
Bonsoir,
=SOMMEPROD((MOIS(A1:A20)=8)*(B1:B20))
ou tu mets le numéro du mois dans une cellule exemple en F2
=SOMMEPROD((MOIS(A1:A20)=F2)*(B1:B20))
idem pour les années
=SOMMEPROD((ANNEE(A1:A20)=2015)*(B1:B20))
ou
=SOMMEPROD((ANNEE(A1:A20)=F2)*(B1:B20))
et pour le mois et l'année
=SOMMEPROD((MOIS(A1:A20)=8)*(ANNEE(A1:A20)=2015)*(B1:B20))
ou
=SOMMEPROD((MOIS(A1:A20)=F2)*(ANNEE(A1:A20)=F1)*(B1:B20))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
Richrdk Messages postés 32 Date d'inscription jeudi 10 septembre 2015 Statut Membre Dernière intervention 14 décembre 2019 2
13 mai 2016 à 21:19
Ça marche!

Merci Mike-31 :)
0