Remplacer une lettre par un chiffre dans EXCEL [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
vendredi 22 avril 2016
Statut
Membre
Dernière intervention
23 avril 2016
-
 BHB87 -
Bonjour,

Pouvez-vous m'indiquer la formule à utiliser pour remplacer ou substituer une lettre dans une case par un chiffre dans une autre case sachant que la valeur dans la 1ère case peut changer et je souhaiterai que la valeur dans la 2ème case change en même temps.

Par exemple, si j'ai dans A1 la lettre "A", je souhaite que B1 se transforme en "1" et si je mets dans A1 la lettre "B", je souhaite que b1 se transforme en "2" et ainsi de suite pour toute l'alphabet comme suit : A=1, B=2, C=3, D=4...Z=26.

J'espère que mes explications sont claires et que quelqu'un pourra m'aider.

Vous remerciant à l'avance.

2 réponses

Messages postés
2471
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
9 juin 2021
1 130
Bonjour tester
=UNICODE(A1)-64
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Bonjour yclik

excellente idée,

....mais chez moi, fonctionne avec =CODE(A1)-64 pas avec UNICODE
par ailleurs cette option donne un résultat différent selon que la lettre soit majuscule ou minuscule
(sans doute la suppression de UNI dont mon Excel ne veut pas)

si cela est un problème on peut contourner avec:

=CODE(MAJUSCULE(A1))-64

crdlmnt
Messages postés
5561
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
6 juin 2021
616 >
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021

Bonjour Vaucluse

Pour les minuscules, a étant en A1

=CODE(A1)-96
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Vi.. Philou, bien d'accord, mais le but était de répondre à la demande dans tous les cas de figure, minuscule ou majuscule, et non pas soit l'un soit l'autre!
Messages postés
26064
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juin 2021
5 953
Bonjour

au plus simple faites un tableau hors champ ou sur une autre feuille avec par exemple
en Y de Y1 à Y26 les lettres de l'alphabet
en ligne en Z les N° correspondants

et dans votre cellule à équiper:

=RECHERCHEV(A1;$Y$1:$Z$26;2;0)

que vous pouvez compléter avec:

=SI(A1="";"";RECHERCHEV(A1;$Y$1:$Z$26;2;0))

pour éviter un affichage d'erreur quand A est vide
Bonjour,
Merci pour votre réponse, c'est exactement ce que je voulais faire et ça fonctionne à la perfection ;-)
Encore merci.