Changer couleur cellule selon valeurs dans une liste [Résolu/Fermé]

Signaler
Messages postés
37
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
6 février 2017
-
Messages postés
37
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
6 février 2017
-
Salut tous le monde,

J'ai 6 celulles disons de A1 à A6 sur feuille 1.
et sur feuilles 2 j'ai on va dire 3 colonnes qui vont de A1 à C2000 chacune avec une référence différente. Une référence est composée de 3 lettres et 5 chiffres.
Je veux que si je rentre une reference dans l'une des 6 cellules de la feuille 1 et que cette reference existe dans l'une des 3 colonnes de la feuille 2 bin la couleur de la cellule en question de la feuille 1 change.
J'ai trouvé plein d'info sous la mise en forme conditionnelle mais que pour une seule valeur.

quelqu'un à une idée svp et sans VBA s possible.

Merci

1 réponse

Messages postés
25213
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 août 2020
5 396
Bonjour

il faut passer par une MFC par formule

mais comme vos données de références ne sont pas sur la même feuille ils faut nommer vos champs

par exemple si vous voulez une couleur spécifique par liste de références, à adapter
feuille 2 A1:A2000 nommer par exemple : List_1
L
feuille 1, sélectionnez A1:A6
Onglet accueil / Mise en forme conditionnelle / "Nouvelle règle"
et
"utiliser une formule...."
entrez cette formule:
=NB.SI(List_1;A1)>0
et formatez

et pour les autres listes, recommencez en cliquant sur "nouvelle règle " dans la fenêtre de MFC

bien sur si vous n'appliquez qu'une couleur pour les trois types de références de feuille 2, nommer d'un seul nom tout le champ A:C

si besoin, pour nommer, plusieurs solutions:
soit sélectionner le champ et inscrire le nom choisi dans la case adresse à gauche de la barre et formule et enter
soit sélectionner le champ et ruban / formule / définir un nom
(pas de blanc ni de signe opérateur dans les noms)

crdlmnt


Messages postés
37
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
6 février 2017

Merci Beaucoup c'est pil poil ce que je souhaitais.
Une excellente journée
Messages postés
37
Date d'inscription
mercredi 16 décembre 2015
Statut
Membre
Dernière intervention
6 février 2017

Encore une dernière question stp.
Si je veux que ma cellule A1 de feuille 1 change de couleur que pour certaines valeurs de la liste A:C de la feuille 2 qui commencent par exemple par "XYZ"
Comment faire?
MErci