RechercheV sur des cellules fusionnées

Résolu/Fermé
Signaler
Messages postés
10
Date d'inscription
mercredi 24 février 2016
Statut
Membre
Dernière intervention
17 novembre 2016
-
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
-
Bonjour,


Pouvez-vous m'indiquer s'il est possible, et si oui, comment effectuer une rechercheV "vers des cellules fusionnées".

Dans mon printscreen, avec la formule, j'aurais voulu voir apparaitre "Phase 1" dans la cellule E2 grâce à la formule RechercheV.

D'avance merci pour votre aide,
Bien à vous,
Emdii

2 réponses

Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
28
Bjr,

Lorsque vous fusionnez des cellules, en réalité seule la première cellule en haut à gauche contient le texte, les autres sont "vide". Donc elles existent encore mais sont vides et à ce titre vos formules renverront un vide (ou 0 dans le cas d'une recherchev).

Un seul conseil : pas de cellules fusionnées lorsque les données doivent encore être traitées :-)

Bonne continuation,
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
10
Date d'inscription
mercredi 24 février 2016
Statut
Membre
Dernière intervention
17 novembre 2016

Merci beaucoup pour votre réponse.

Cet état de fait est extrêmement décevant !!
Vous n'en pouvez rien, j'exprime ma grande déception envers microsoft pour un logiciel bureautique pourtant "à la pointe" et cher...
Messages postés
10
Date d'inscription
mercredi 24 février 2016
Statut
Membre
Dernière intervention
17 novembre 2016
>
Messages postés
10
Date d'inscription
mercredi 24 février 2016
Statut
Membre
Dernière intervention
17 novembre 2016

Je vais donc me débrouiller et ajouter un onglet caché "raw data" qui va me servir de base de données relationnelles...
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
28
Il y a une autre manière que par recherchev, une petite minute et je vous donne ça
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
28
Voilà, alors il faut utiliser la formule suivante à partir de la ligne 2 à dérouler vers le bas en formule matricielle (valider avec Ctrl+Shift+Entrer au lieu de juste Entrer) :
=INDEX(B:B;MAX(SI((B:B<>"")*(LIGNE(B:B)<LIGNE(A2));LIGNE(B:B))))
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
28
Attention cette solution en formule matricielle demandera pas mal de ressources à Excel, donc à ne pas utiliser si vous avez beaucoup de lignes :/
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 981
Bonjour,

ce n'est pas vraiment d'un recherchev() que tu as besoin.
Commence tes données 1 ligne plus bas et en E2 :
=SI(B2="";E1;B2)
eric

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci