Formule SI avec texte et dates?

Résolu/Fermé
audrey - 20 févr. 2016 à 15:09
 Audrey - 21 févr. 2016 à 14:06
Bonjour,

J'ai en colonne A les dates de début d'un mandat (ex : 20 février), en colonne B: les dates de fermeture du dossier (ex : 23 février) et en colonne C, le nombre de jours entre le début et la fin du traitement (donc 3, ce qui correspond à 3 jours)

exemple : C1=B1-A1

Ce que j'aimerais, c'est que le calcul pour les jours se fasse toujours en colonne C, mais qu'en plus, si j'inscrit par exemple 'Annulé' en colonne B, que le résultat en colonne C corresponde donc à '0'. Le tout fonctionne bien avec =SI(NB.SI(B1;"*Contenu*");"0";"").

Je n'ai pas de problème avec aucune de ces deux formules, mais comme il n'est possible d'en mettre qu'une seule dans chaque cellule, est-ce qu'il y aurait possibilité de n'en trouver qu'une seule pour rendre les deux résultats désirés??

Ps : pas de macro, pas de VBA, connaissances très limitées! :) merci de votre aide!

1 réponse

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 308
Modifié par Vaucluse le 20/02/2016 à 15:22
Bonjour
on ne comprend pas très bien ce que vous avez en B1 pour détecter "contenu" avec NB.SI ?
à tout hasard

=SI(B1="annulé";0;B1-A1)

ou encore si toutefois annulé est inclus dans un texte en B1

=SI(NB.SI(B1;"*annulé*");0;B1-A1)


et si B1 n'est pas rempli parce qu'en cours:

=SI(ET(A1>0;B1="");"en cours";SI(B1="annulé";0;B1-A1;""))


et bien entendu la même que précédemment pour B1 annulé
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 308
20 févr. 2016 à 15:39
curieux, vous êtes sure? c'est bien de B1 que nous parlons?
voyez ici:
https://www.cjoint.com/c/FBuoMOBNcQx
crdlmnt
0
Audrey > Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022
21 févr. 2016 à 14:06
Bon évidemment c'était moi le problème et non votre formule! Ça fonctionne à merveille et à voir la simplicité du truc, je réalise que mes connaissances sont plus que limitées! Haha! Merci beaucoup Vaucluse d'avoir pris le temps de me répondre :-)
0
Bon voilà, problème résolu! merci beaucoup!
0