Calcul de valeurs, selon une date variable [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
mercredi 6 janvier 2016
Statut
Membre
Dernière intervention
22 février 2016
-
Messages postés
2657
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 juillet 2021
-
Bonjour,

Je viens vers vous car j'ai un soucis qui est le suivant : il me faut calculer un nombre de valeurs sur une ligne "équipe", en me basant sur une autre ligne "date", qui serait évolutive dans le temps.
Au fur et à mesure j'incrémente la ligne "équipe" par un numéro, et il me faudrait le total de l'équipe "2" sur les deux derniers mois.

Exemple :


Je n'ai pas réussi avec les formules DECALER (...).

C'est pourquoi j'aurai besoin de votre. Merci par avance !

4 réponses

Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 992
Bonjour
1°) qu'entendez vous par les deux dernies mois? les deux derniers mois complets ou le mois en cours + le précédent
2°) vos équipes sont bien identifiées par les N° 1,2 etc. dans la ligne 4

Voyez avec, pour équipe 1 en C8 en supposant que vos colonnes mois vont de B à IV (à adapter)

=SOMMEPROD(($B$4:$IV$4)=LIGNE(A1)*(MOIS($B$3:$IV$3)=MOIS(AUJOURDHUI())+SOMMEPROD((MOIS(($B$3:$IV$3)=MOIS(FIN.MOIS(AUJOURDHUI();-1))))
vous obtiendrez le nombre de 1 dans la ligne 3 pour les mois concernés et en tirant vers le bas, le nombre de 2 de trois etc.??

si ce n'est pas ça, revenez avec plus de précisions...

crdlmnt
Messages postés
2657
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 juillet 2021
1 587
Bonjour,

Si j'ai bien compris il s'agit simplement de compter le nombre de fois que l’équipe 2 apparaît au cours des 2 dernier mois C'est ça?:

-Si c'est le cas Cette fonction peut marcher:
=SOMMEPROD((C:C=2)*1;(JOURS(AUJOURDHUI();D:D)<61)*1)

(J'avoue avoir essayer pour tomber avec mois , mais un bug apparaissait et me faisait mal les calculs quand c'était sur plusieurs années...)

A adapter suivant le numéro de l'équipe que tu veux

Cordialement
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 992
Bonjour Diablo

pas tout à fait bien appris la leçon......:-))):

SOMMEPROD ne fonctionne pas avec C:C etc..mais avec C3:X3 par exemple
le *1 n'est pas utile ici et mal placé dans tous les cas, et le point virgule n'a rien à faire là

=SOMMEPROD((C4:X4=2)*(C3:X3>AUJOURDHUI()-61))

qui donnera le total des 2 sur les 60 jours avant aujourd'hui

bien cordialement
Messages postés
2657
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
21 juillet 2021
1 587 >
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021

Bonjour Vaucluse


Hmmmm J'ai oublier de faire cette modification ... mes test était en Verticale et non horizontal comme la situation actuelle . C'est ma faute me suis précipité a recopier quand j'avais trouvé mais pas penser a m'adapter au contexte :/

Du coup dans ma tête j’étais persuadé que ça passé

On peut pas devenir un As en 1 jour de SommeProd;)

Merci de m'avoir Corrigé:)

Cordialement
Messages postés
5
Date d'inscription
mercredi 6 janvier 2016
Statut
Membre
Dernière intervention
22 février 2016

Bonjour à tous !

Je vous remercie pour la rapidité de vos réponses !

J'ai bien eu la solution grâce à vos diverses réponses et je resterais sur celle de Vaucluse qui correspond parfaitement à ma situation. Je l'ai légèrement modifiée pour mon tableau, et c'est parfait !

Merci à tous et passez un bon week end.

Continuez à aider la population, vous nous sortez de belles épines du pied !

Cordialement
Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
25
Bonjour,

Si je comprends bien, vous voulez calculer le nombre d'occurrence sur la ligne 4 pour chaque équipe (de 1 à 5 dans le screenshot).

Si oui, tu peux utiliser en C8 :
=NB.SI(4:4;1)

Il faudra veiller à laisser la ligne 4 réservée au n° d'équipe

Si vous voulez ajouter une condition sur les dates (n'avoir que les deux derniers mois par exemple), nb.si.ens sera plus pratique :
=NB.SI.ENS(4:4;1;3:3;">="&MOIS.DECALER(AUJOURDHUI();-2))