Si cellules excel contiennent tel texte, calculer pourcentage

Résolu/Fermé
Bonzo - 3 févr. 2016 à 09:33
 Bonzo - 3 févr. 2016 à 10:07
Bonjour,

J'ai dans un fichier excel plusieurs colonnes dont une qui indique le domaine d'activité des usagers d'un produit. Un de ces domaines est "général".
Cette colonne comporte 100 lignes.

J'aimerais trouver une formule qui me permettent de calculer automatiquement dans cette colonne le pourcentage d'usagers "général" et de l'afficher dans une autre cellule de mon choix (imaginons, la cellule J12)

Merci par avance pour votre aide.

2 réponses

diablo13800
Messages postés
2790
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 mai 2022
1 775
3 févr. 2016 à 09:42
Bonjour,

Vous pouvez utiliser cette formule pour calculer le pourcentage de personne dont le domaine est générale (a adapter et peut-être pas la plus optimale)
vous n'avez qu'a la mettre dans la cellule que vous voulez:
=NB.SI(B:B;"général")/NBVAL(B:B) *100
5
Idem, la formule marche parfaitement.

Merci beaucoup !
0
Fahora
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Modifié par Fahora le 3/02/2016 à 09:43
Bonjour ,

La formule suivante devrait convenir :
=(NB.SI(A1:A4;"général")/NB.SI(A1:A4;"*"))*100


En adaptant la plage , bien évidemment.

cordialement,

Nos seuls limites sont celles que nous nous imposons nous-même.
Fahora
0
Merci, ça marche parfaitement !
Bonne journée.
0