Différence entre dates et moyenne [Résolu/Fermé]

Signaler
-
Messages postés
9755
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 octobre 2020
-
Bonjour,

Je cherche à afficher dans un cellule la différence entre deux dates, sur plusieurs jours et faire ma moyenne des jours cumulés.

La formule pour les différences de date est, si je ne me trompe, =datediff(date1;date2;"d").

Si c'est correct, cela me donne un résultat du type : 2 jour(s).

Là où j'ai un problème c'est pour le nombre cumulé des jours.

Je fais la somme (=somme()) des résultats mais cela me donne : #VALEUR!.

Comme je suis une bille avec Excel, je m'adresse à vous pour quelques pistes.

Je vous remercie d'avance.


2 réponses

Messages postés
9755
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 octobre 2020
1 077
Bonjour,
Juste au passage,

Je fais la somme (=somme()) des résultats mais cela me donne : #VALEUR!.

C’est quoi l’instruction complète de la fonction =SOMME(…………….)

Bonjour,

L'instruction est =SOMME(I38:I62) les cellules I38 à I62 correspondant à =DATEDIF(B36;H38;"d") etc.

Je ne sais pas si je suis clair.
Messages postés
23583
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020
6 415
Bonjour,

DATEDIF() retourne une chaine.
Pour une simple différence en jours : = date2 - date1
eric
Bonjour Eriiic,

Merci de votre réponse, c'est effectivement plus simple et cela permet d'afficher le nombre de jours cumulés. Super et merci encore.

Toutefois, petite question, lorsque ma cellule Date2 est vide, cela me donne -40911 (je crois savoir que cela correspond à une date "numérique"). Mais comment faire pour que cela me retourne 0 et n'entre pas dans le total cumulé.
Messages postés
23583
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020
6 415
date vide = 00/01/1900
=si(date2="";"";date2-date1)
ou si(date2="";0;date2-date1) comme demandé mais je pense qu'il faut distinguer d'un vrai 0
>
Messages postés
23583
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020

Merci Eriiic,

Je vais regarder ça et oui tiens au courant.

Bonne soirée.
>
Messages postés
23583
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 octobre 2020

Eric vous êtes un génie !

La première formule marche impeccablement.

Je vous remercie beaucoup, et très bonne soirée à vous.
Messages postés
9755
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
10 octobre 2020
1 077
Merci eriiic pour la prise en main.
Amicales salutations
Le Pingou