Rechercher sur une liste de données la plus petite valeur [Fermé]

Signaler
-
Messages postés
17227
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 septembre 2020
-
Bonjour,

Je souhaiterais trouver la formule qui permet d'afficher pour considérer cette valeur comme base de référence, la valeur la plus petite sur une sélection de plusieurs valeurs, mais différente de zéro.

2 réponses

Messages postés
17227
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 septembre 2020
4 237
Bonsoir,

en formule normale moins gourmande en ressource

=PETITE.VALEUR(A1:A20;NB.SI(A1:A20;0)+1)

et avec gestion d'erreur pour Excel supérieur à 2007
=SIERREUR(PETITE.VALEUR(A1:A20;NB.SI(A1:A20;0)+1);"")
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60588 internautes nous ont dit merci ce mois-ci

Messages postés
850
Date d'inscription
vendredi 13 février 2015
Statut
Membre
Dernière intervention
15 février 2019
38
Bonjour,

Formule matricielle (exemple avec des données allant de A1 à A15) :

=MIN(SI(A1:A15>0;A1:A15))

(pour entrer une formule matricielle, entrez la formule simplement dans la cellule telle qu'elle puis au lieu d'appuyer sur "Entrée", il faut faire Ctrl + Maj + Entrée)

Cordialement.