Calculer le nombre de valeurs différentes suivant un critère

Résolu/Fermé
MontSouris Messages postés 8 Date d'inscription jeudi 5 novembre 2015 Statut Membre Dernière intervention 25 juillet 2016 - 5 nov. 2015 à 22:24
via55 Messages postés 13977 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 4 décembre 2022 - 6 nov. 2015 à 17:23
Bonsoir,

Cela fait depuis plusieurs jours déjà que je cale sur un formule de mon tableau Excel.

Je vous explique mon problème:
Mon classeur excel comporte plusieurs colonnes parmi lesquelles
A : Villes françaises
AF: Dates de livraison
Et ce, sur plus 5000 lignes

En l'état, j'aimerais pouvoir calculer le nombre de dates différentes parmi la colonne AF, et pouvoir filtrer ce nombre par rapport aux villes que j'ai sélectionnées. J'ai utilisé la formule suivante:
=SOMMEPROD((1/NB.SI.ENS(LISTES!$AF$4:$AF$5000;LISTES!$AF$4:$AF$5000)))
Cependant, le résultat ne correspond qu'au nombre de dates différentes dans la colonne AF, à savoir 319.
J'aimerais pouvoir affiner ce résultat en fonction de ma colonne A, Villes françaises.

Dans la pièce-jointe ci-dessous, je devrais pouvoir trouver 5 pour Aix, 3 pour Ajaccio etc.

Enfin, j'aimerais pouvoir affiner la formule pour ne prendre en compte que les dates à partir de Juillet 2015. Est-ce que cela est possible?

J'espère avoir été assez clair!

Je vous remercie d'avance pour votre aide précieuse :)

1 réponse

via55 Messages postés 13977 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 4 décembre 2022 2 526
6 nov. 2015 à 00:27
Bonsoir

Essaie :
=NB(1/FREQUENCE(SI(A:A="Aix";EQUIV(AF:AF&A:A;AF:AF&A:A;0));LIGNE(INDIRECT("1:"&LIGNES(AF:AF)))))
formule matricielle à valider par Ctrl+Maj+Entrée (la formule se met alors automatiquement entre {} )
formule empruntée à Jacques Boisgontier, voir :http://boisgontierjacques.free.fr/

Cdlmnt
Via
1
MontSouris Messages postés 8 Date d'inscription jeudi 5 novembre 2015 Statut Membre Dernière intervention 25 juillet 2016
6 nov. 2015 à 01:31
Magnifique!! Ca marche parfaitement!

Je me permets d'abuser de ton aide ; sais-tu comment ajouter un critère de date dans la formule?
- A savoir prendre les dates à partir du 01/07/2015
- Ou chaque mois à partir du 01/07/2015

Je te remercie énormément pour ton coup de main

Cordialement,
0
via55 Messages postés 13977 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 4 décembre 2022 2 526 > MontSouris Messages postés 8 Date d'inscription jeudi 5 novembre 2015 Statut Membre Dernière intervention 25 juillet 2016
6 nov. 2015 à 17:23
Re,

Pour ne comptabiliser que les dates à partir du 01/07/2015 essaie cette autre formule matricielle :
=NB(1/FREQUENCE(SI((A:A="Aix")*(AF:AF>=DATEVAL("01/07/2015"));AF:AF);AF:AF))

Cdlmnt
Via
0