Somme dans colonne par groupe selon critères dans colonne adjace [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
dimanche 1 novembre 2015
Statut
Membre
Dernière intervention
2 novembre 2015
-
Messages postés
17193
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 mai 2020
-
Bonjour,
je souhaiterai faire des sommes partielles de valeurs contenue dans une colonne
en fonction de critères se trouvant dans une autres colonne
le résultat apparaissant dans une colonne adjacente.
ex:
col:A(critère) Col:B(Nombre) Col:C(somme de B selon critère A)
ligne1 fil 7
ligne2 fil 4
ligne3 fil 2 13
ligne4 bobine 12
ligne5 bobine 3 15

en utilisant somme.si.ens et plusieurs autres tentatives
je ne m'en sort pas
quelqu'un peut-il m'aider

2 réponses

Messages postés
17193
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 mai 2020
4 054
Bonsoir,

tu colles cette formule en C1 et tu l'incrémente vers le bas

=SI(A1=A2;"";SOMMEPROD(($A$1:A1=A1)*($B$1:B1)))

si tu as une version Excel supérieure à 2007
=SI(A1=A2;"";SOMME.SI.ENS($B$1:B1;$A$1:A1;A1))

ou encore
=SI(A1=A2;"";SOMME.SI($A$1:A1;A1;$B$1:B1))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
17193
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 mai 2020
4 054
Et encore un doublon qui nous promène et fait travailler pour rien

https://forums.commentcamarche.net/forum/affich-32726934-somme-partielle-conditionnelle#p32727421

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.