Somme de cellules contenant un mot

Résolu/Fermé
Signaler
-
Messages postés
16546
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 janvier 2022
-
Bonjour,

Voici mon exemple:

A B
2 Projet 1
3 Projet 2
4 Facture 1
5 Facture 2

Je souhaiterais faire la somme de toutes les cellules A associées aux cellules B contenant le mot projet. En l'occurence, le résultat ici serait 5. Pouvez-vous m'aider svp?

Merci beaucoup,

Sarah.
A voir également:

3 réponses

Messages postés
16546
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 janvier 2022
3 259
errereur


Michel
0
comment ca erreur? je parle d'additionner le contenu des cellules A associees aux cellules B contenant le mot projet, en l'occurence les cellules contenant les nombres 2 et 3, ce qui donne 5
0
Messages postés
16546
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 janvier 2022
3 259
eh bé, susceptible ce(cette) sarahsh !!!
C'était une erreur de ma part ! sinon, j'aurais dit pourquoi il y avait une erreur

Alors:
MILLE EXCUSES LES PLUS HUMBLES EN ESPËRANT QUE VOTRE GRANDE BONTE. VEUILLE BIEN ME PARDONNER

Mais j'éviterais à l'avenir de vous importuner en répondant à vos demandes car j'ai trop peur de vous froisser.
0
haha non ca m a pas froissé du tout xd
0
Messages postés
16546
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 janvier 2022
3 259 > sarahsh
Qu'est ce que ca ^tre alors ...

adieu
0
Messages postés
26394
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2022
6 182
Bon jour (salut michel)

je pense que l'erreur de l'ami Michel devait être une erreur, car je ne vois pas pourquoi il ne vous aurait pas dit:

=SOMME.SI(B:B;"*Projet*";A:A)

ou si vous inscrivez par exemple Projet en C1

=SOMME.SI(B:B;"*"&C1&"*";A:A)


crdlmnt
0
Merci, en fait j'ai besoin de poser deux conditions

exemple
A | B | C
2 |Projet 1 | 2015
3 | Projet 2 | 2014
4 |Facture 1 | 2015
5 |Facture 2 | 2014

Donc en fait je souhaite faire la meme chose que tout à lheure en rajoutant la condition C=2015, merci d'avance pour votre aide,

Sarah
0
Messages postés
26394
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2022
6 182
Re

Excel à partir de 2007:
=SOMME.SI.ENS(A:A;B:B;"*Projet*";C:C;2015)

Excel avant 2007:

=SOMMEPROD((GAUCHE(B2:B1000;5)="Projet")*(C2:C1000=2015)*(A2:A1000))

dans ce code numéros de lignes obligatoires et rien que des valeurs num dans le champ A concerné.

crdlmnt
0
désolée je vais paraitre chiante :p en fait ca n'était qu'un exemple, je pensais que la méthode était la même pour cet exemple que pour mon fichier réel.
En vrai, j'ai dans ma colonne B du texte avec 'MFG:textile' ou 'COMM:tourism' , du coup il me faudrait récupérer les cellules contenant MFG et COMM séparemment.
Je vous donne l'exemple réel:

A (capacité en MW) | B (secteur d'activité) | C (statut de l'installation)

12 | COMM:tourism | OPR
20 | MFG:mining | OPR
40 | MFG:textile | PLN

Du coup je veux additionner les puissances des installations du secteur d'activité MFG (mining, textile etc..) qui sont en opératiàon ( status : OPR)

en espérant que c est la derniere fois que je vous dérange

Merci bien,

Sarah
0
Messages postés
26394
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2022
6 182
vi... c'est pas gentil de pas tout dire d'un coup!
mais je ne vois pas ce que ça change, du moins avec la formule SOMME.SI.ENS, car il suffit de placer le texte à détecter entre les astérisques.
=SOMME.SI.ENS(A:A;B:B;"*MRG*";C:C;"OPR")
Pour SOMMEPROD, c'est une autre histoire, mais là encore, vous ne dites pas quel est l'age de votre excel
A suivre?
crdlmnt
0