Recherche d'une fontion adaptée [Résolu/Fermé]

Signaler
-
 lily3901 -
Bonjour,

Je cherche une fonction excel dans le style de la fonction SI, mais a plusieurs entrées.
Je m'explique.
J'ai un tableau de données en nombres et j'aimerais créer une colonne qui mette des commentaires différents suivant les résultats chiffrés.
Par exemple
- inferieur à 10 = MAUVAIS
- de 10 a 50 = A AMELIORER
- au dessus de 50 = BON
Un peu dans le genre de la mise en forme conditionnel, sauf que je ne veux pas que le résultat soit une mise en forme, mais un terme donné.

J'espère etre clair et que vous pourrez m'aider.

2 réponses

Messages postés
12863
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
28 novembre 2020
2 072
Bonjour

C'est bien des fonctions SI imbriquées que tu peux utiliser, en supposant apr exemple le résultat en B2, dans une autre cellule la formule :

=Si(B2<10;"Mauvais";SI(B2<50;"A améliorer";"Bon"))

Cdlmnt
Via
J'ai essayée mais ça me met l'erreur #NOM?
Messages postés
4148
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1 323 > lily3901
Bonjour

N'oublie pas les ""
Crdlt
Messages postés
25620
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 novembre 2020
5 626
Si la formule vous renvoie nom, c'est qu'elle trouve un libellé qu'elle ne sait pas lire.
Avez vous mis les guillemets aux bons endroits?
C'est bon, ca marche.
J'aivais en effet oublier un guillemet.
Merci Beaucoup pour vos réponses.
Messages postés
25620
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 novembre 2020
5 626
Bonjour
=SI(A1="";"";SI(A1<10;"Mauvais";SI(A1<50;"à améliorer";"Bon")))
crdlmnt