Dual boot vista xp boot xp impossible

[Résolu/Fermé]
Signaler
-
Messages postés
1131
Date d'inscription
vendredi 17 septembre 2004
Statut
Membre
Dernière intervention
9 juin 2011
-
Bonjour , je possede deux disque dur : un maxtor de 30 Go et un Hitachi de 120 Go.

Sur le premier etait installé windows xp pro.
Je le deconnecte de mon pc (enlevement de nappe / molex) pour installer vista (sans qu'il fasse la mise a jour xp-> vista)

J'installe vista sur le Hitachi . Tout se passe bien.

Je rebranche l'autre disque dur , tout deux sont reconnus par le bios

Dans la gestion de demarage du bios , je peux choisir dans quel DD il va demarrer l'os.

Si je met le premier (maxtor) il me demare XP , si je met le second (hitachi) il me demarre vista sans probleme.

J'ai voulu le passé en dual boot (pour ne pas m'ennuyer a aller dans le bios [ce que je fait actuellement])

je telecharge donc vista boot pro il me reconnait xp , je reboot.

Au demarrage le bios me demande bien quel os je veux , je boot windows xp , il me met une erreur indiquant que le fichier "ntldr" est introuvable.

Je cherche donc des tutos sur le net et je tombe sur ceci

Dans vista , ouvrez le cmd en mode administrateur (clic droit , ouvrir en tant que)
et tapez ceci :

"BCDEDIT /set {ntldr} device partition=E:" (dans ce cas la , windows vista reconnait le disque dur xp en tant que E , et le vista en tant que C: [et xp pro donne C: pour le DD xp pro , et G pour le dd vista Oo non?])

Je tape donc cette commande et j'obtiens

Opération reussie

Je reboot
J'essaye de lancer XP mais... mais mais

lorsque j'apuis sur entrée j'ai un reboot.. donc voila ... si quelqu'un a la solution... merci de m'aider :)

21 réponses

Messages postés
1131
Date d'inscription
vendredi 17 septembre 2004
Statut
Membre
Dernière intervention
9 juin 2011
88
Démarre avec la console de réparation (F10 au démarrage, ou bien boote sur le disque d'installation de Windows). A l'invite de commande tape fixboot C:. Reboot.
Messages postés
453
Date d'inscription
dimanche 25 mars 2007
Statut
Membre
Dernière intervention
7 août 2010
7
peut étre XP mal installé
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

nope xp n'est pas mal installé ... je tente le fixboot
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

moi.néo aurais tu msn pour que tu puisse m'aider en direct si je puis dire

car j'ai tenter F10 au demarrage , rien ne se passe , j'ai lancé le cd de windows dans le bios et il commençait a vouloir me le reinstaller alors n'aurai til pas moyen de lancer le fixboot autrement?
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

console de reparation = console de recupération? (http://support.microsoft.com/kb/307654/fr)
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

j'ai bien fait un fixboot mais lorsque je remet l'Hitachi en ide boot , et que je met windows xp , sa reboot toujours......
Messages postés
1131
Date d'inscription
vendredi 17 septembre 2004
Statut
Membre
Dernière intervention
9 juin 2011
88
Excuse, je me suis trompé, c'est la console de récupération.
Va voir ça : https://www.zebulon.fr/dossiers/windows/61-console-de-recuperation.html
et va voir en particulier la section "Réparer le secteur de boot".
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

Alors résumé : en copiant tout les ntldr et ntdetect sur mon disque C:\ (xp) rien , cependent en les copiant dans la racine du disque dur vista petit changement , maintenant c'est boot.ini qu'il manque , donc je supose qu'en copiant le boot.ini que j'ai sur xp et en le mettant a la racine de vista ça devrait marcher . (et je tente sans risque d'endommager vu que si 'jai bien pigé vista utilise un autre systeme de boot)
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

Fiou 3h13 du matin , je vous parle en direct de vista (jai remis le boot a partir du deuxieme DD pour tester)

Alors apres la copie de boot.ini 3 option au choix

Microsoft Windows Vista
Microsoft Windows XP Professionnel
Cosole de r_cup_ration Microsoft windows xp

je met donc windows xp pro

Puis encore un menu avec

Microsoft Windows XP Professionel
Console de récupération microsoft windows xp (bien ecris ce coup-ci)

je vais enlever la ligne du boot.ini de vista pour que console de r_cup_ration n'aparaissent plus .
cepedant lorsque je met Windows xp professionel , mon ecran est noir et aparement reste noir (j'ai la flemme d'attendre vers 3h du mat)

donc j'abandonne la lutte et je la reprend demain ^^ en esperant que tu sois toujours a mes coté pour mon avancer contre le fléau dual boot
Messages postés
1131
Date d'inscription
vendredi 17 septembre 2004
Statut
Membre
Dernière intervention
9 juin 2011
88
T'as essayé fixboot ?
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

oui en premier fixboot :C
apres meme probleme
apres copy de ntldr et de ntdetect.com vers la partition vista

nouvelle erreur : boot.ini manquant

copy du boot.ini vers la partition vista

nouvel affichage au boot :

vista xp console recup je met xp

réaffichage XP console recup

je met xp , et la un ecran noir.
Messages postés
1131
Date d'inscription
vendredi 17 septembre 2004
Statut
Membre
Dernière intervention
9 juin 2011
88
C'est pas fixboot :C mais fixboot C: !
Essaie avec fixboot tout seul.
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

bah je l'avais deja fait fixboot C: j'ai just fiat une faute de frape , mais j'ai fait Fixboot maintenant la partition de destination est C: j'ai accepter je reboot je tente de lancer xp , je remet encore une seconde fosi xp , et le black screen de la mort
Messages postés
1131
Date d'inscription
vendredi 17 septembre 2004
Statut
Membre
Dernière intervention
9 juin 2011
88
Essaie un fixmbr.
Ca permet de réparer le secteur de démarrage principal de la partition système. Comme fixboot, tu peut préciser le nom du lecteur ; met celui sur lequel tourne Xp.
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

lol ok je tente ^^
Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

sa a po marché
je croi que les 2 d.dur son maitre de la méme nap tu doit verrifier les jumper
il faut que 1 soit maitre -2 soit esclave

nope , au debut ils etaient tout les deux en maitre mais il y avait un conflit donc seul l'un des deux etait pris en compte , des que j'ai installé l'hitachi , je l'ai mis en slave , d'ailleurs au boot y'a bien ecrit

primary master : maxtor
primary slave : hitachi
secondary master : asus (mon graveur dvd ram)
secondary slave : none
Messages postés
1131
Date d'inscription
vendredi 17 septembre 2004
Statut
Membre
Dernière intervention
9 juin 2011
88
Le problème c'est que t'as 2 DD avec 2 OS différent dessus et en plus, ces 2 0S n'utilise pas les même fichiers de boot : xp utilise boot.ini et vista bcd !

Regarde ce logiciel : VistaBootPro : http://www.kachouri.com/tuto/tuto-206-vistabootpro-31--multi-boot-avec-vista.html

Messages postés
11
Date d'inscription
vendredi 6 juillet 2007
Statut
Membre
Dernière intervention
8 juillet 2007

lol trop tard j'ai fait plus simple :

Soluce complete pour que le dual boot marche niquel:


dans mon cas

Formater partition/disque dur ou y'a vista
Installer vista depuis xp
Selectionner installer sur un autre disque dur

et puis le dual boot s'obtiens tout seul sans probleme , et je pense que avec vista boot pro on peut modifier l'option :

version antérieure de windows en windows xp mais je suis pas sur

ps: moi.néo j'etais deja passer par vista boot pro