Comparaison de 2 fichiers excel et résultat dans un 3ème [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mardi 19 mai 2015
Statut
Membre
Dernière intervention
20 mai 2015
-
Messages postés
3
Date d'inscription
mardi 19 mai 2015
Statut
Membre
Dernière intervention
20 mai 2015
-
Bonjour à toutes et tous,
Je suis débutant en excel et vraiment mauvais en informatique (ça pose les bases) ^^

J'espère donc que vous pourez m'aider à résoudre mon problème :

Je souhaite comparer deux versions d'un fichier excel (un ancien et l'update).
Pour ce faire, j'ai un dossier maître contenant un fichier excel vide.
En mettant dans ce dossier les deux fichiers que je veux comparer, il faudrait que mon fichier excel vide se remplisse.

Pour être plus précis :



Voilà le fichier type qui est à comparer avec sa version précédente.

grâce aux deux fichiers (ancien et update) mon fichier vide compare les lignes du fichier le plus récent avec l'autre.
Si une ligne dans le fichier le plus récent n'est pas identique à une ligne de l'ancien fichier, alors la ligne entière apparaît dans le troisième fichier vide.

Je ne sais pas si j'ai été suffisament clair et précis.

Merci d'avance pour votre aide :)

2 réponses

Messages postés
5525
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
30 octobre 2020
516
Bonjour
Dans le classeur3 Feuil1 en A1 vous pouvez mettre cette formule

=SI([Classeur1]Feuil1!$A$1=[Classeur2]Feuil1!$A$1;"";[Classeur2]Feuil1!$A$1)
Si les 2 classeurs ne sont pas identique affiche les données du classeur2 Feuil1 A1
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
mardi 19 mai 2015
Statut
Membre
Dernière intervention
20 mai 2015

je ne comprend pas ce que vous voulez faire.
Je voudrais avoir un dossier windows avec une feuille excel vierge dedans.
Lorsque dans ce dossier j'ajoute les deux fichiers excel (le vieux et l'updaté), il faut que les lignes du nouveau fichier que l'on ne retrouve pas dans l'ancien apparaissent dans le 3ème fichier vierge. Mais dans les deux fichiers sources, les lignes ne sont peut être pas rangé dans le même ordre, c'est pour cela qu'il faut chercher une correspondance pour chaque.
Sinon, on peut peut être faire plus simplement sans utiliser le 3ème fichier vierge, mettre en highlight les lignes du nouveau fichier qui n'étaient pas dans l'ancien.
Le but de cette fonction est qu'elles soit réutilisable dans d'autres cas pour comparer des lignes de fichiers différents.
Messages postés
5525
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
30 octobre 2020
516
Bonjour

Vous voulez contrôler les différences entre deux feuilles d'un le même classeur

=SI(ESTERREUR(EQUIV(A2;Feuil1!A:A;0));"nouveau";"")

Pour un contrôle sur la colonne A
Recherche A2 dans la colonne A de la feuil1
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
mardi 19 mai 2015
Statut
Membre
Dernière intervention
20 mai 2015

merci beaucoup, ça m'aide :) j'ai réussi à faire ce que je voulais.