Formule avec RECHERCHEV et CONCATENER.

Résolu/Fermé
Signaler
Messages postés
25
Date d'inscription
dimanche 27 juillet 2014
Statut
Membre
Dernière intervention
18 septembre 2016
-
 Excel_tab1 -
Bonsoir,
J'ai besoin de vos lumières pour m'éclairer sur le sujet suivant.
En effet, j'ai différents éléments ARI, BOK et C-RE dans mon deuxième onglet d'un fichier Excel.
Lorsqu'on met ces éléments en stock, ceux-ci sont codés sous la forme stockARI, stockBOK et stockCRE.
Dans mon premier onglet, j'ai donc stockARI, stockBOK et stockCRE.
Les quantités sur stockARI, stockBOK et stockCRE sont connues et sont placées en deuxième colonne.
Je souhaite attribués les quantités sur stockARI, stockBOK et stockCRE respectivement aux éléments A,B et C.
J'utilise la formule =RECHERCHEV(CONCATENER("stock",$A2),Feuil1!A:C,2,0)
Celle-ci fonctionne pour les éléments éléments ARI, BOK mais pas pour C-RE sans doute à cause du tiret situé entre C et RE.
Quelle formule pourrais-je utiliser pour attribuer le stockCRE à l'élément C-RE ?
J'espère que mon explication est claire
Je vous remercie d'avance.
Cordialement.
Seb

3 réponses

Messages postés
13206
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
1 décembre 2021
2 289
Bonsoir Seb

Essaie :
=RECHERCHEV("stock"&GAUCHE(A2;1)&DROITE(A2;2),Feuil1!A:C,2,0)

(on prend le 1er caractère à gauche et les 2 à droite)

Cdlmnt
Via
Messages postés
25
Date d'inscription
dimanche 27 juillet 2014
Statut
Membre
Dernière intervention
18 septembre 2016
1
Bonsoir Via,

Merci pour l'idée et la formule.

Je vais la tester et je te tiendrai au courant.

Cordialement.

Seb
Messages postés
26305
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 décembre 2021
6 131
Bonjour
une variante, juste en passant histoire de saluer via
si les titres à chercher sont en A2
=RECHERCHEV("*"&SUBSTITUE(A2;"-";"");Feuil1!AC;2;0)
crdlmnt

Errare humanum est, perseverare diabolicum
Bonjour à tous,

Les solutions proposées par Via et Vaucluse sont OK.

Un grand merci à vous.

Cordialement.

Seb