Excel, fonction RECHERCHEV me retourne "0" quand champ vide [Résolu/Fermé]

Signaler
Messages postés
15110
Date d'inscription
lundi 8 septembre 2008
Statut
Membre
Dernière intervention
6 avril 2021
-
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
-
Bonjour,

dans un fichier Excel, j'utilise la fonction RECHERCHEV pour copier une ligne d'information correspondant à la sélection que je fais dans la première case de la ligne, parmi une liste déroulante.

En plus clair, j'ai une liste de noms (colonne A) et diverses informations pour chaque nom (colonnes B, C, D...).
Dans une case, j'ai une liste déroulante où je peux sélectionner n'importe quel nom. Et grâce à la fonction RECHERCHEV, j'affiche automatiquement les informations correspondantes au nom sélectionné dans les cases à droite.

Le problème : lorsqu'une case contenant une information est vide, la fonction RECHERCHEV retourne comme valeur "0". Et donc, affiche "0" dans la case.
Je voudrais qu'elle n'affiche rien, dans ce cas.

Comment faire?

Merci à la communauté.

3 réponses

Messages postés
12983
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 avril 2021
2 163
Bonsoir

Avec une condition SI tu vérifies si la valeur est 0, ex :
=SI(RECHERCHEV(H1;A1:D100;2;0)=0;"";RECHERCHEV(H1;A1:D100;2;0))

Cdlmnt

3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 391
Bonjour,

Il te suffit de mettre un format personnalisé
@;;""

Si tu as un zéro comme valeur, il ne sera pas affiché.
Messages postés
15110
Date d'inscription
lundi 8 septembre 2008
Statut
Membre
Dernière intervention
6 avril 2021
2 240
Merci!

Concrêtement, je colle ça où?!
Messages postés
15110
Date d'inscription
lundi 8 septembre 2008
Statut
Membre
Dernière intervention
6 avril 2021
2 240
OK, trouvé, mais le format personalisé @;;"" ne fonctionne pas sous Excel 2007
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 543
Bonsoir,

hors l'option afficher un zéro dans les cellules qui ont une valeur nulle,
perso j'utilise deux formats personnalisés
Standard;Standard;;@
0;0;;@
ou encore
Standard;;;@
0;;;@
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
15110
Date d'inscription
lundi 8 septembre 2008
Statut
Membre
Dernière intervention
6 avril 2021
2 240
" j'utilise deux formats personnalisés
Standard;Standard;;@
0;0;;@
ou encore
Standard;;;@
0;;;@ "

Donc quatres... pas deux.

Le premier fonctionne. Merci!
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 543
Non, celui ci
Standard;Standard;;@
ou celui ci sont les mêmes à part que je ne répète pas le "standard" ou le 0
Standard;;;@

comme les deux autres d'ailleurs