Excel, fonction RECHERCHEV me retourne "0" quand champ vide

Résolu/Fermé
Erwan031284
Messages postés
15120
Date d'inscription
lundi 8 septembre 2008
Statut
Membre
Dernière intervention
18 mars 2022
- 21 mars 2015 à 19:24
Mike-31
Messages postés
17945
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 mai 2022
- 30 mars 2015 à 19:58
Bonjour,

dans un fichier Excel, j'utilise la fonction RECHERCHEV pour copier une ligne d'information correspondant à la sélection que je fais dans la première case de la ligne, parmi une liste déroulante.

En plus clair, j'ai une liste de noms (colonne A) et diverses informations pour chaque nom (colonnes B, C, D...).
Dans une case, j'ai une liste déroulante où je peux sélectionner n'importe quel nom. Et grâce à la fonction RECHERCHEV, j'affiche automatiquement les informations correspondantes au nom sélectionné dans les cases à droite.

Le problème : lorsqu'une case contenant une information est vide, la fonction RECHERCHEV retourne comme valeur "0". Et donc, affiche "0" dans la case.
Je voudrais qu'elle n'affiche rien, dans ce cas.

Comment faire?

Merci à la communauté.

3 réponses

via55
Messages postés
13595
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 mai 2022
2 401
21 mars 2015 à 21:45
Bonsoir

Avec une condition SI tu vérifies si la valeur est 0, ex :
=SI(RECHERCHEV(H1;A1:D100;2;0)=0;"";RECHERCHEV(H1;A1:D100;2;0))

Cdlmnt

4