Extraire des lignes d'un tableau [Résolu/Fermé]

Signaler
-
 Audrey -
Bonjour,

j'ai un tableau Excel avec les colonnes A, B, C, D dans l'onglet Database.
Je souhaite copier certaines lignes de ce tableau dans un autre onglet du classeur (Extrait)avec pour critère certaines valeurs de la colonne A et de la colonne C.
Ces valeurs filtre je les saisi dans l'onglet Extrait dans les cases A1 et A2.
Filtre: valeur(colonne A) = A1 ET valeur(colonneC)=A2

Merci pour votre aide!

A voir également:

1 réponse

Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
5 864
Bonjour

Pour ressortir l'ensemble des valeurs:


= INDEX(Database!A:D;EQUIV(A1&A2;Database!A:A&Database!C:C;0);1)

Cette formule est matricielle et doit être entrée avec la touche Enter en maintenant ctrl et shift enfoncées. elle se trouve automatiquement entre accolade dans la barre de formule.

La formule ci dessus renvoie la valeur de la colonne A du champ A:D de Database
pour B remplacer le ;1) par;2)... ect...

Si cette formule peut ne pas trouver de résultat, écrire:
=SI(ESTERREUR(Formule);"";formule)
pour éviter l'affichage d'erreur du type #N/A

crdlmnt

Errare humanum est, perseverare diabolicum
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
25948
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2021
5 864
... en complément, je réalise que vous pouvez avoir plusieurs lignes à ressortir.
Voyez donc si vous pouvez ce modèle à vos données.
https://www.cjoint.com/?CJkndtpx9Fd

revenez si besoin de complèment
crdlmnt
Merci beaucoup, ça marche très bien!!