Formule "SI" combinées

[Résolu/Fermé]
Signaler
Messages postés
7
Date d'inscription
jeudi 13 mars 2008
Statut
Membre
Dernière intervention
23 juin 2015
-
Messages postés
7
Date d'inscription
jeudi 13 mars 2008
Statut
Membre
Dernière intervention
23 juin 2015
-
Bonjour,
Je suis sous Windows 7 et Excel 2010 et je me casse la tête depuis plusieurs heures.
Voilà, je voudrais combiner des conditions "SI" dans une formule comme suit:

Si la case A1=0, la case A2 se remplie automatiquement avec "TOTO"
Si la case A1>0 mais <100, la case A2 se remplie automatiquement avec "TATA"
Si la case A1=100, la case A2 se remplie automatiquement avec "TITI".

J'ai écris la formule suivante qui me renvoie une erreur de "valeur":
=SI(A1=0;"TOTO");SI(ET(A1>=1;A1<100);"TATA";"TITI")

Chacune des conditions marche individuellement mais quand je les combinent j'ai l'erreur de valeur.
Quelqu'un peut-il m'aider SVP
Merci d'avance
BSD59

3 réponses

Messages postés
17419
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 juillet 2021
4 672
Bonjour,

regarde comme cela

=SI(A1>=100;"TITI";SI(A1>0;"TATA";SI(ET(A1=0;A1<>"");"TOTO";"")))
après il faut jouer avec les > ou >= etc pour adapter à ses besoins ainsi que les si(et(
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
5570
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
29 juillet 2021
628
Bonjour

=SI(A1=0;"toto";SI(ET(A1>0;A1<100);"tata";SI(A1=100;"titi";"")))
Messages postés
7
Date d'inscription
jeudi 13 mars 2008
Statut
Membre
Dernière intervention
23 juin 2015

Merci, les 2 formules marchent très bien.
Même si je n'y viens pas souvent, je constate que l'entraide sur le forum marche toujours aussi bien.
Encore merci
BSD59

--