Trouver une valeur correspondant a deux critères [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
mercredi 5 novembre 2014
Statut
Membre
Dernière intervention
14 avril 2016
-
Messages postés
25606
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
-
Bonjour, je rencontre un problème pour un tableau excel et pour faire simple :

J'ai un tableau avec toutes mes données :

Pour un produit il peut y avoir plusieurs dates, a chaque couple produit/date il y a un code unique.
A noter que deux produits différents peuvent être à la même date.

Produits Date Code


Produit 1 01/01/2000 100 001
Produit 1 02/02/2000 100 002
Produit 1 03/03/2000 100 003
Produit 2 01/01/2000 100 004
Produit 2 02/05/2002 100 005
Produit 2 03/03/2002 100 006
Produit 2 03/04/2002 100 007
Produit 3 03/03/2000 100 008
Produit 3 04/04/2004 100 009

dans un second tableau J'ai une colonne avec mes produits, et une colonne avec leur date, je souhaite faire une troisième colonne qui m'indiquerai le code a 6 chiffre correspondant au couple Produit/date sur la même ligne, en se référant au premier tableau.

Produits Date Code

Produit 1 03/03/2000 ?
Produit 2 02/05/2002 ?
Produit 1 02/02/2000 ?
Produit 2 03/03/2002 ?
Produit 3 04/04/2004 ?


Merci d'avance je bloque complètement,

1 réponse

Messages postés
25606
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
5 618
Bonjour

à adapter:
à partir de ligne 2:

premier tableau colonne A,B,C

deuxième tableau colonne D E F

en D produit
en E date
en F la formule

=SIERREUR(INDEX(C:C;EQUIV(D2&E2;AA&B:B;0));"")

formule matricielle à entrer avec la touche Enter en maintenant ctrl et shift enfoncées.
(elle doit s'afficher automatiquement entre accolades dans la barre de formule)

crdlmnt

Messages postés
11
Date d'inscription
mercredi 5 novembre 2014
Statut
Membre
Dernière intervention
14 avril 2016
1
Bonjour,

D'abord merci pour la formule, seulement aucune valeur n'apparaît dans la cellule, j'ai appuyer sur ctrl+shift+entrée, les acollades sont apparues, mais aucune valeur ne s'affiche...
Messages postés
25606
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
5 618
Alors c'est que nous n'avez pas de cas où D2 et E2 sont sur la même ligne dans le tableau
Voyez ici:
https://www.cjoint.com/c/DKgknOI8Bxr
notez aussi que pour la capacité fichier, il est préférable pour une formule matricielle de limiter les champs par des N° de ligne
(voyez la formule en F2 limitée sur ligne 1 à 50)
sinon la matricielle considère toute la hauteur de colonne (et ça prend un peu de emps)

crdlmnt
Messages postés
11
Date d'inscription
mercredi 5 novembre 2014
Statut
Membre
Dernière intervention
14 avril 2016
1
Parfait, tout fonctionne, Merci ennormément.
Messages postés
25606
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 novembre 2020
5 618
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt