Recherchersi une donnée est déja existante (chronologie)

[Fermé]
Signaler
-
Messages postés
24202
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour,

Je dois vérifier que des numéros de série revenants n'ont pas déja été connus par le passé.
J'ai donc un fichier chronologique et il me faut savoir si je retrouve la valeur.
Je sais faire un VLOOK UP (=recherche verticale (Excel est en anglais)) mais voudrais apprendre comment traiter différemment ce cas.

date n°série entrant n°série sortant
01 01 aa ab
02 01 xa xa
03 01 qb xc
04 01 ab ab


Sauriez vous m'aider?
Je vous en serais bien reconnaissante et sinon, bien évidemment, merci quand même.

2 réponses

Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
En D2 par ex
=SI(ET(A2<>"";NB.SI(C$2:C2;C2)>1);"doublon";"")
à tirer vers le bas

mais au lieu d'une formule, tu peux utiliser une Mise en forme conditionnelle
Messages postés
24202
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 937
Bonjour à tous,

Est-ce que tu contrôles indépendamment les n°série entrant et les n°série sortant, ou bien dois-tu contrôler leur présence dans les 2 colonnes ?
Si c'est le cas 2, il faudra adapter la proposition de michel
Tu peux aussi retourner le n° de ligne où il apparait en 1er

eric