Mettre les débits en nombres négatifs

Résolu/Fermé
FidelDiPaz
Messages postés
2
Date d'inscription
lundi 23 juin 2014
Statut
Membre
Dernière intervention
23 juin 2014
- 23 juin 2014 à 13:28
Bruce Willix
Messages postés
11912
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
- 23 juin 2014 à 15:59
Ma banque est flemmarde, elle met les montants sans signe dans la colonne A et la mention "débit" ou "crédit" dans la colonne B. Pour m'y retrouver, je souhaite connaître le moyen de mettre en négatif les montants correspondant aux débits... Comment faire ?

5 réponses

via55
Messages postés
13880
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
26 septembre 2022
2 490
23 juin 2014 à 13:56
Bonjour

Une possibilité, créer une colonne C Crédit et une colonne D Débit
en C2 mettre la formule=si(b2="crédit";a2;"") et en D2 la formule si(b2="débit";0-a2;"")
Et étirer les formules aux bas des colonnes

Cdlmnt
1
Bruce Willix
Messages postés
11912
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 625
23 juin 2014 à 14:00
plus élégant ^^
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 183
23 juin 2014 à 14:10
Parmi toutes ces solutions, celle qui se rapproche le plus de ta question initiale est la dernière, proposée par Vaucluse, et qui peut se réduire à saisir en C2 la formule
=SI(B2="Débit";-A2;A2)
1
Bruce Willix
Messages postés
11912
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 625
Modifié par Bruce Willix le 23/06/2014 à 14:00
Non, ta banque est logique... les débits et crédits peuvent, tous les deux, prendre des valeurs positives ou négatives, principes comptables obligent.

Pour ta question tu peux faire :

=SI(A1="crédit";B1;-B1))


Sword of Omens, give me Sight beyond Sight...
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
23 juin 2014 à 14:20
Bonjour Bruce
je me suis permis de supprimer le -1 qui t'avait été affecté car on aurait bien du mal à savoir pourquoi
bien amicalement
0
Bruce Willix
Messages postés
11912
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 625
23 juin 2014 à 15:59
Bah, m'étais planté dans ma première soluce. Pô grave ^^
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
Modifié par Vaucluse le 23/06/2014 à 13:58
Bonjour
vous pouvez recréer une colonne
exemple
information crédit ou débit en colonne A, montant en colonne B
en colonne C:
=SI( A1="Débit";B1*-1;SI(A1="Crédit";B1;""))

crdlmnt

Errare humanum est, perseverare diabolicum
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
FidelDiPaz
Messages postés
2
Date d'inscription
lundi 23 juin 2014
Statut
Membre
Dernière intervention
23 juin 2014

23 juin 2014 à 14:57
Merci à tous ! Et merci Raymond d'avoir résumé cette formule.
0