Entre deux valeurs ( fonction si)

[Résolu/Fermé]
Signaler
Messages postés
2
Date d'inscription
lundi 19 mai 2014
Statut
Membre
Dernière intervention
20 mai 2014
-
Messages postés
2
Date d'inscription
lundi 19 mai 2014
Statut
Membre
Dernière intervention
20 mai 2014
-
Bonjour,

Je me remets depuis peu à Excel et j'aurai besoin d'aide pour une formule!

Je bloque sur une démarche dans la fonction si:

(Pour mieux visualiser mon soucis, je copie le tableau si dessous)

-Si x ( une autre cellule ) est inferieur ou égal a2.9 alors on prend le coeff 2,35 jusque ici ça va (=SI(S12<=2,69;O8;)
Et je voudrai faire suivre les autres mais je bloque ici:
Si x est inferieur ou égal 4,29=2,00. Si X est entre 4,30 et 6,29= 1,65
C'est le entre que je ne sais pas comment retranscrire et m'amène a vous demander votre aide.

J'espère être clair et que l'un de vous aura quelques minutes a m'accorder.
Tonnage Coeff Payant Pour (T)
1,1-3T 2,35 2,70
3,1-5T 2,00 4,30
5,1-7T 1,65 6,30
7,1-10T 1,45 8,80
10,1-15T 1,25 13,40
15,1-20T 1,10 18,30
20,1-23T 1,00 22,00
23,1T et + 0,95

Cordialement

Bilbo


4 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 537
Bonjour,

Une façon de le faire de façon plus facilement modifiable avec un petit tableau barème :

https://www.cjoint.com/?DEtvPeTOWME
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
17603
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 octobre 2021
4 793
Bonsoir,

Pas très clair et surtout tes exemples ne correspondent pas ou ne figure pas dans la liste
avec un peu d'imagination et suivant ton tableau

si dans la cellule S12 il y a une valeur > 23 on affiche 0,95
si par contre on saisi une valeur entre 20,1 et 23 on affiche 1,00 etc etc ... c'est bien cela
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
17603
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 octobre 2021
4 793
Re,

Pas de réponse du demandeur, je poste la formule que j'avais préparé

=SI(S12>23,1;0,95;SI(S12>20;1;SI(S12>15;1,1;SI(S12>10;1,25;SI(S12>7;1,45;SI(S12>5;1,65;SI(S12>3;2;SI(S12>1;2,35;""))))))))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
lundi 19 mai 2014
Statut
Membre
Dernière intervention
20 mai 2014

Bonjour,

Désolé de ne pas avoir répondu plutôt et merci a tous les deux pour vos réponses.

Vos deux méthodes me sont utile et désolé de ne pas avoir été très clair!

Mike: tu as bien compris dans l'exemple donné.


Merci 100 fois a vous,

Cordialement

Biblo