Somme si

Résolu/Fermé
Signaler
-
Messages postés
17826
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
-
Bonjour,

pourriez-vous me donner la formule somme si pour ignorer les NA et les cellules vides ?


Merci d avance.

9 réponses

Messages postés
17826
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
4 915
Bonjour,

#N/A ou autre sont des messages d'erreurs qu'il est possible de gérer mais pour cela il faut connaitre la formule utiliser et surtout la version d'excel

pour utiliser soit la fonction SI(ESTERREUR
ou SIERREUR
0
=SOMME(D20;D24;D28;D32;D36;D40;D45;D45;D44;D48;D52)

sur excel 2007
0
Messages postés
17826
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
4 915
Re,

normalement cette formule ne doit pas renvoyer un message d'erreur sauf si une des cellules de la formule est elle même en erreur

tu peux compléter la formule comme ceci mais l'idéal serait de traiter l'erreur à la base

=SIERREUR(SOMME(D20;D24;D28;D32;D36;D40;D45;D45;D44;D48;D52);"")

si tu peux joindre ton fichier utilise ce lien

https://www.cjoint.com/

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
il n y a pas d erreur c jusque que par exemple D52 est vide car rien produit cette semaine ou juste case libre pour un futur agent
0
Messages postés
17826
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
4 915
Re,

ta formule ne doit pas renvoyer d'erreur même s'il y a des cellules vides ou contenant du texte, contrairement à une formule du type =cellule+cellule etc...

serait t il possible d'avoir ton fichier
0
http://cjoint.com/?3DioCICOQqz
0
Messages postés
17826
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
4 915
Re,

Je t'ai un peu modifié les formules de la colonne F cellules que j'ai colorisées en jaune, j'ai remplacé FAUX par 0 ce qui fait gagner 2 octet par formule

recontrôle tes formules de la ligne 57 je pense que F45 ajouté deux fois est une erreur comme sa présence d'ailleurs

=SOMME(F20;F24;F28;F32;F36;F40;F45;F45;F44;F48;F52)

https://www.cjoint.com/?DDiplGf7Q7r
0
thanks you
0
Messages postés
17826
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 janvier 2022
4 915
Avec plasir, applique les modifs à toutes tes formules pour alléger le fichier, dans le même soucis nomme tes plages exemple pour la feuille S4 plage $A$1:$O$50 (S4'!$A$1:$O$50) si tu nommes la plage exemple S_4

la formule en F20 =SIERREUR(RECHERCHEV($A20;'C:\Users\www\AppData\Local\Temp\FACTU\[FACTU.xls]S4'!$A$1:$O$50;3;0);"")

deviendrait

=SIERREUR(RECHERCHEV($A20;'C:\Users\www\AppData\Local\Temp\FACTU\[FACTU.xls]S_4;3;0);"")

économie de 11 octets par formule multiplié par X formules plusieurs dizaines KO voir MO de moins par fichier
0