JOOMLA - Probleme de type Warning lié à timezone [Résolu/Fermé]

Signaler
Messages postés
85
Date d'inscription
mardi 13 janvier 2009
Statut
Membre
Dernière intervention
13 janvier 2020
-
Messages postés
85
Date d'inscription
mardi 13 janvier 2009
Statut
Membre
Dernière intervention
13 janvier 2020
-
Bonjour tout le monde!
je suis administrateur du site afrik11.com basé sur JOOMLA 1.5.26, et depuis quelque je suis confronté a un problème de time_zone.
En effet lorsque j'entre dans la gestion des articles de l'administration, voici les warning qui s'affichent:


Warning: strtotime() [function.strtotime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'GMT/0.0/no DST' instead in /home/afrikwry/public_html/libraries/joomla/utilities/date.php on line 56


Warning: mktime() [function.mktime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'GMT/0.0/no DST' instead in /home/afrikwry/public_html/libraries/joomla/utilities/date.php on line 117

Warning: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'GMT/0.0/no DST' instead in /home/afrikwry/public_html/libraries/joomla/utilities/date.php on line 250


je tiens a préciser que cela se passe uniquement lorsque je veux éditer un nouvel article.
Alors je sollicite votre aide pour solutionner ce problème.

MERCI
Cordialement

1 réponse

Messages postés
85
Date d'inscription
mardi 13 janvier 2009
Statut
Membre
Dernière intervention
13 janvier 2020
7
Ok...merci a vous tous même si vous ne m'avez pas répondu.
J'ai trouvee la solution:
- Soit il faut mettre a la ligne 17 du fichier date.php cette ligne: date.timezone = "Europe/Paris"
-ou si vous avez acces au fichier php.ini il faut y ajouter date.timezone = "Europe/Paris"

Cordialement....