Fonction NB.SI.ENS différentes plages même critère

Résolu/Fermé
Murielle!!
Messages postés
70
Date d'inscription
jeudi 28 novembre 2013
Statut
Membre
Dernière intervention
8 février 2021
- 9 mars 2014 à 16:13
Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
- 9 mars 2014 à 20:47
Bonjour,

Je veux utiliser la fonction NB.SI.ENS pour différentes plages qui sont dans plusieurs onglets, mais j'ai le même critère. Et ça ne fonctionne pas, je ne connais pas d'autres fonctions qui pourraient y ressembler.

Merci de votre aide


Excel 2010

3 réponses

Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
910
Modifié par Mytå le 9/03/2014 à 20:12
Salut le Forum

Une autre facon de faire

=SOMMEPROD(NB.SI(INDIRECT("'"&{"Feuil1"."Feuil2"."Feuil3"}&"'!" & {"A1:A100"."B2:B50"."C10:C20"});"A"))

Mytå

Merci de donner suite à votre question, nous ne sommes pas des robots...
« Si le déboguage est l'art d'enlever les bogues, alors la programmation doit être l'art de les créer. »
2
Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
910
9 mars 2014 à 20:21
Re le Forum

Ou en combinant les feuilles et cellules dans la même matrice.

=SOMMEPROD(NB.SI(INDIRECT({"'Feuil1'!A1:A100"."'Feuil2'!B2:B50"."'Feuil3'!C1:C10"});"A"))

Mytå
0
Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
530
9 mars 2014 à 17:28
Bonjour,

Le principe est le même avec la fonction NB.SI.ENS
Exemple :
=NB.SI.ENS(Feuil1!B9:B13;"A";Feuil2!F4:F8;"A";Feuil3!C2:C6;"A")
applique les critères aux cellules des 3 plages et compte le nombre de fois où tous les critères sont remplis.

A+
1
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 262
Modifié par Vaucluse le 9/03/2014 à 17:33
Bonsoir Gyrus
je ne crois pas que le résultat soit le même, la fonction n'additionnera pas, mais va compter uniquement les lignes où le A se retrouve sur la même ligne dans toutes les feuilles mais pas le total des A dans les trois feuilles
L'équivalent en NB.SI serait:
=NB.SI(Feuil1!A:A;"A")+NB.SI.... ect
crdlmnt
0
Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
530
9 mars 2014 à 20:47
Bonsoir Vaucluse,

Exact !
J'étais parti sur la formulation
=SOMMEPROD((Feuil1!B10:B14="A")*(Feuil2!F5:F9="A")*(Feuil3!C3:C7="A")*1)

Cordialement.
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 262
Modifié par Vaucluse le 9/03/2014 à 17:35
Bonjour
essayez avec ce principe qui compte les "A" dans trois feuilles en colonne A de ligne 1 à 100:

=SOMMEPROD(((Feuil1!A1:A100="A")+(Feuil2!A1:A100="A")+(Feuil3!A1:A100="A"))*1)
attention aux parenthèses, il y en a des poignées!
placez le nombre de feuilles que vous voulez
Note: le code SOMMEPROD exige des adresses de champ avec des N° de ligne,(ex A1:A100 mais pas A:A)
les champs doivent avoir le même nombre de lignes (mais peuvent être décalés)

crdlmnt
Errare humanum est, perseverare diabolicum
0
Murielle!!
Messages postés
70
Date d'inscription
jeudi 28 novembre 2013
Statut
Membre
Dernière intervention
8 février 2021

9 mars 2014 à 17:25
Merci beaucoup Vaucluse, ça fonctionne :)
0