Fonction NB.SI.ENS différentes plages même critère [Résolu/Fermé]

Signaler
Messages postés
70
Date d'inscription
jeudi 28 novembre 2013
Statut
Membre
Dernière intervention
8 février 2021
-
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
-
Bonjour,

Je veux utiliser la fonction NB.SI.ENS pour différentes plages qui sont dans plusieurs onglets, mais j'ai le même critère. Et ça ne fonctionne pas, je ne connais pas d'autres fonctions qui pourraient y ressembler.

Merci de votre aide


Excel 2010

3 réponses

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
850
Salut le Forum

Une autre facon de faire

=SOMMEPROD(NB.SI(INDIRECT("'"&{"Feuil1"."Feuil2"."Feuil3"}&"'!" & {"A1:A100"."B2:B50"."C10:C20"});"A"))

Mytå

Merci de donner suite à votre question, nous ne sommes pas des robots...
« Si le déboguage est l'art d'enlever les bogues, alors la programmation doit être l'art de les créer. »
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
850
Re le Forum

Ou en combinant les feuilles et cellules dans la même matrice.

=SOMMEPROD(NB.SI(INDIRECT({"'Feuil1'!A1:A100"."'Feuil2'!B2:B50"."'Feuil3'!C1:C10"});"A"))

Mytå
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
514
Bonjour,

Le principe est le même avec la fonction NB.SI.ENS
Exemple :
=NB.SI.ENS(Feuil1!B9:B13;"A";Feuil2!F4:F8;"A";Feuil3!C2:C6;"A")
applique les critères aux cellules des 3 plages et compte le nombre de fois où tous les critères sont remplis.

A+
Messages postés
25837
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 793
Bonsoir Gyrus
je ne crois pas que le résultat soit le même, la fonction n'additionnera pas, mais va compter uniquement les lignes où le A se retrouve sur la même ligne dans toutes les feuilles mais pas le total des A dans les trois feuilles
L'équivalent en NB.SI serait:
=NB.SI(Feuil1!A:A;"A")+NB.SI.... ect
crdlmnt
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
514
Bonsoir Vaucluse,

Exact !
J'étais parti sur la formulation
=SOMMEPROD((Feuil1!B10:B14="A")*(Feuil2!F5:F9="A")*(Feuil3!C3:C7="A")*1)

Cordialement.
Messages postés
25837
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 793
Bonjour
essayez avec ce principe qui compte les "A" dans trois feuilles en colonne A de ligne 1 à 100:

=SOMMEPROD(((Feuil1!A1:A100="A")+(Feuil2!A1:A100="A")+(Feuil3!A1:A100="A"))*1)
attention aux parenthèses, il y en a des poignées!
placez le nombre de feuilles que vous voulez
Note: le code SOMMEPROD exige des adresses de champ avec des N° de ligne,(ex A1:A100 mais pas A:A)
les champs doivent avoir le même nombre de lignes (mais peuvent être décalés)

crdlmnt
Errare humanum est, perseverare diabolicum
Messages postés
70
Date d'inscription
jeudi 28 novembre 2013
Statut
Membre
Dernière intervention
8 février 2021

Merci beaucoup Vaucluse, ça fonctionne :)