Nb si + critères mois [Fermé]

Signaler
-
Messages postés
1
Date d'inscription
lundi 6 janvier 2014
Statut
Membre
Dernière intervention
6 janvier 2014
-
bonjour,

je voulais compter le nombre de cellules d'une première colonnes en fonction d'un critère de dates (mois)

par exemple
A1 : P
A2 : G
A3: G
A4 : S

B1 : 01/01/14
B2: 01/01/14
B3 : 02/01/14
B4 : 02/02/14

je voudrais simplement créer un autre tableau récapitulatif à coté en mettant dans la colonne D1, D2, D3, D4 les mois Janvier 2014, Fev2014, mars 2014, avril 2014, et comptabilisé dans la colonne E1, F1, G1, le nombre de P, G, et S pour chaque mois.

Merci d'avance pour vos réponses
A voir également:

3 réponses

Messages postés
25809
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2021
5 781
Bonjour

NB.SI n'extraira pas le mois de la date pour aller chercher dans la clonne d'a coté

essayez avec
=SOMMEPROD((MOIS(B1:B1000)=1)*(A1:A1000="P"))
avec 2 pour janvier, =2 pour février ect..

Notez que ce code exige des limites de colonne et de lignes dans les adresse
ou alors, à artir d'exclel 2007,mais un peu plus compliqué, avec:
=NB.SI.ENS(B:B;"1/2/2014";A:A;"P") pour janvier
et ensuite
=NB.SI.ENS(B:B;">31/1/2014";B:B">1/3/2014";A:A;"P") pour février ect....

bien sur vous pouvez remplacer "P" par l'adresse de la cellule où P est inscrit, mais cette fois sans guillemets

Crdlmnt
Messages postés
23886
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 février 2021
6 659
Bonjour,

Autre possibilité avec un Tableau Croisé Dynamique qui est étudié pour (aucune formule ni liste de valeur à saisir) :
https://www.cjoint.com/c/DAgmcpyEnhM

Les TCD demandent un temps d'apprentissage (déposer les bons champs au bon endroit) mais ce temps est rentabilisé ensuite vu leur puissance.

Un tableau de données doit toujours avoir une ligne de titre si tu veux les manipuler correctement sur excel.

eric
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu lorsque c'est le cas (en haut vers votre titre).
Merci
Messages postés
1
Date d'inscription
lundi 6 janvier 2014
Statut
Membre
Dernière intervention
6 janvier 2014

Merci infiniment pour vos réponses, et désolé pour le double post je suis nouveau sur le forum