Additionner les résultat,s d'une rechercheV [Résolu/Fermé]

Signaler
Messages postés
324
Date d'inscription
dimanche 12 mai 2013
Statut
Membre
Dernière intervention
10 mars 2020
-
Messages postés
52268
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2020
-
Bonjour,

Je souhaiterais additionner les résultats de mes rechercheV mais je n'arrive pas à trouver la combinaison des formule.
Exemple:
Feuil1: j'ai une liste de produit:
A1
A2
A3
A4
Feuil2: j'ai une liste de ces produits avec les quantités commandées, c'est à dire:

Date Produit Quantité
Datexx: A1: 12
Datexx: A2: 30
Datexx: A1: 34
Dtaexx: A4: 156
Datexx: A3: 34
Datexx: A2: 167

Je souhaiterais additionner les résultats de mes rechercheV de mes produits de la liste Feuil1 à partir de la Feuil2: Autrement dit, en effectuant la rechercheV du produit A1 de la feil1 dans la colonne Quantité sur la Feuil2, je dois obtenir 12+34=46

Je vous remercie d'avance pour votre aide, c'est vraiement urgent pour moi de pouvoir trouver la solution.

2 réponses

Messages postés
25280
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 septembre 2020
5 463
Bonjour
Ce n'est pas RECHERCHEV qu'il vous faut mais, SOMME.SI
Exemple à adapter
en Feuil1 en A, la liste exhaustive de référence de vos produits à partir de A2
en Feuil2 en A la liste des références et en B la liste des quantités
en feuil1 en B2, à tirer sur la hauteur utile:

=SOMME.SI(Feuil2!A:A;A2;Feuil2!B:B)



crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
324
Date d'inscription
dimanche 12 mai 2013
Statut
Membre
Dernière intervention
10 mars 2020
3
Merci Vaucluse! votre solution marche bien.
Messages postés
52268
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2020
14 053
Au revoir.
Messages postés
52268
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 septembre 2020
14 053
Je précise à l'intention de celui qui m'a mis -1 que lorsque j'ai répondu, à 13:27, le message de senecartour était le suivant : "Bonjour".

Il a donc réagi à ce message en rédigeant enfin sa demande, modification datée de 13:36 !