Imbriquer les fonctions ET et OU [Résolu/Fermé]

Signaler
Messages postés
284
Date d'inscription
jeudi 12 janvier 2012
Statut
Membre
Dernière intervention
18 septembre 2019
-
Messages postés
284
Date d'inscription
jeudi 12 janvier 2012
Statut
Membre
Dernière intervention
18 septembre 2019
-
Bonjour,

Je souhaiterai insérer une formule en ayant besoin des 2 fonctions ET et OU. Mais je ne sais pas comment les insérer en même temps.

Si vous auriez une petite astuce :)
Merci d'avance

4 réponses

Messages postés
48206
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
12 octobre 2020
6 247
Bonjour,

Les réponses sont données par des personnes, pas par des robots. Merci d'user des formules de politesse courante (bonjour, merci, s'il vous plait...).

Pour répondre à ta question, cela dépend de la logique à appliquer aux éléments du calcul... "A et (B ou C)" est différent de "(A et B) ou C"
Messages postés
284
Date d'inscription
jeudi 12 janvier 2012
Statut
Membre
Dernière intervention
18 septembre 2019
8
Voici les conditions :

Si A1 = "Messagerie" ET B1 est compris entre 100 et 180 kg OU 301 et 490kg OU supérieur à 700 kg.
(si c'est vrai il m'affiche un prix), si c'est faux :

SI A1= "Messgaerie" ET B1 est inférieur à 100kg OU compris entre 181 et 300 kg OU compris entre 491 et 700kg.
(Il m'affichera un autre prix)

Les 2 conditions sont indispensables car la formule à appliquer n'est pas la même selon les cas, la première concerne un poids au 100kg et la deuxième est un forfait.

Merci pour ton aide
Messages postés
48206
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
12 octobre 2020
6 247
Si je comprends bien, la seconde série de condition est la complémentaire de la première, n'est-ce pas ? Elle est VRAIE quand la première est FAUSSE et vice-versa.

Je construirais donc la première et j'indiquerais dans la fonction SI la valeur "prix forfaitaire" si la première n'est pas réalisée.

=SI((A1="Messagerie")ET(((B1>100)ET(B1<181))OU((B1>300)ET(B1<491))OU(B1>700));[entrer ici la formule de calcul du prix au kg];[entrer ici la valeur du forfait)

Fait sans tester, gaffe aux erreurs de position d'une parenthèse ou à une limite erronée (de 1 kg, mais ça compte...).
Messages postés
52430
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
14 279
... et aussi aux points-virgules qui doivent précéder les ET et les OU !
Messages postés
52430
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
14 279
Bonjour vous deux.

Je proposerais la formule (testée) suivante :
=SI(A1="Messagerie";SI(OU(ET(B1>100;B1<180);ET(B1>301;B1<490); B1>700);"Prix1";"Prix2");"Aucun prix")
Messages postés
48206
Date d'inscription
mardi 8 janvier 2008
Statut
Modérateur
Dernière intervention
12 octobre 2020
6 247
Merc, Raymondi...

Ca fait trois siècles (presque) que je n'ai plus vraiment joué à ça ; ma grammaire "excelente" n'est plus excellente.
Messages postés
284
Date d'inscription
jeudi 12 janvier 2012
Statut
Membre
Dernière intervention
18 septembre 2019
8
"Si je comprends bien, la seconde série de condition est la complémentaire de la première, n'est-ce pas ? Elle est VRAIE quand la première est FAUSSE et vice-versa. "

En fait, il y a 4 voir 5 conditions a imbriquer, mais les autres sont plus simples, il n'y a qu'un seul critère à prendre en compte.

J'ai essayé la formule de Raymond, elle fonctionne (en ayant ramé un peu, la formule faisait 9 lignes et pas moyen de regrouper) :)

Merci à vous deux pour votre aide :)