Fonction SI imbriqués avec ET & OU [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
jeudi 19 février 2015
Statut
Membre
Dernière intervention
10 juillet 2015
-
Messages postés
11
Date d'inscription
jeudi 19 février 2015
Statut
Membre
Dernière intervention
10 juillet 2015
-
Bonjour à tous,

Je viens au secours à cause de ma fonction si imbriqués avec les fonctions ET & OU et je ne sais pas comment les gérér. Voici la formule que j'ai déjà fais puis en bas vous trouverez un exemple des données que je suis en train d'utiliser.
=SI(D3=1;"1";Si(Et(B3<=C3;E3=F3;"1";"0";OU(Si(B3<=C3;E3/F3;"")))))

Date BL------- Date Promise------ OTD Prev---- Qté facturée------ Qté cmdé
28/04/2014-- 28/04/2015 ---------1 ----------------915----------------915
28/04/2014-- 15/03/2014 ---------1 ----------------260----------------260
28/04/2014-- 26/05/2014 ---------0 ----------------7500---------------7980

Merci d'avance en vous souhaitant une bonne journée!

3 réponses

Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
49
Bonjour,

=SI(OU(D3="1";ET(B3<=C3;E3=F3));1;SI(ET(B3<=C3;E3<>F3);E3/F3;0))

P.S : j'ai modifié la formule, car y avait une petite erreur.

Cdlt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
25517
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 novembre 2020
5 585
Bonjour
je ne crois pas qu'elle fonctionne, Excel-worker, je pense que le OU final est en trop, et comme dans les deux cas, il faut considérer B3<=C3, inutile de le répéter:
du moins je crois
par ailleurs il n'est pas non plus utile de placer les 1 entre guillemets.

=SI(OU(D3=1;ET(B3<=C3;E3=F3));1;SI(B3<=C3;E3/F3;0))

crdlmnt
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
49
Bonjour,

Si D3=1 et qu'en même temps on a B3<=C3 et E3<>F3, qui est prioritaire ?

Le signe "<>" veut dire différent

Car on peut avoir les deux conditions vraies sauf si cela est impossible dans ton tableur ?

Merci de préciser
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
11
Date d'inscription
jeudi 19 février 2015
Statut
Membre
Dernière intervention
10 juillet 2015

Bonjour,

Tout d'abord merci pour vos réponses rapides. B3>=C3 est prioritaire face à E3<>F3. La formule de Vaucluse a l'air juste ? ça représente bien la priorité de B3<=C3 non ?
Messages postés
25517
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
7 novembre 2020
5 585
Bonjour*il n' y a pas dans vitre message initial, de cas à con sidérer ou B3>=C3
ma proposition renvoie
si D3=1 : 1
si ensemble, B3 est plus petit pou égal à C3 et E3 égal à F3: 1
si ensemble B3 est plus petit ou égal à C3 et E3 différente de F3: E3/F3
si aucune de ces ensembles de conditions remplies,: 0
crdlmnt
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
49
Coucou le forum,

@ Vaucluse : ma formule marche aussi, j'ai essayé

@ GuyWinfield : Prends la formule que tu veux, si tu prends la mienne en laissant les guillemets à 1, tu donne la priorité à E3 différent de F3. Si tu enlève les guillemets à 1, c'est la même formule que celle de Vaucluse en plus large.

Cdlt
Messages postés
11
Date d'inscription
jeudi 19 février 2015
Statut
Membre
Dernière intervention
10 juillet 2015

Merci Beaucoup à vous 2 !

Bonne journée