Rm Commande introuvable ?!

[Résolu/Fermé]
Signaler
Messages postés
57
Date d'inscription
mercredi 24 juillet 2013
Statut
Membre
Dernière intervention
17 février 2016
-
Messages postés
57
Date d'inscription
mercredi 24 juillet 2013
Statut
Membre
Dernière intervention
17 février 2016
-
Bonjour à tous,

comme cité dans le titre je veux faire supprimer le dossier: tor-browser_fr qui c'est installé dans: /opt/
je fait donc un:
rm -fv tor-browser_fr
(avec les droits root)
mais la console me retourne:
rm--preserve-root : commande introuvable
je me trouve maintenant dans l'impossibilité de supprimer un fichier ou dossier
j'ai tout essayé...
Quelqu'un peut il me dire ce qu'il ce passe ?

(je suis sous Ubuntu 13.04)

1 réponse

Messages postés
11
Date d'inscription
mercredi 13 octobre 2004
Statut
Membre
Dernière intervention
31 août 2013
10
Bonjour,

vérifiez vos alias en tapant la commande :
alias rm


Il y a sûrement un problème du genre

alias rm='rm--preserve-root...'


au lieu de

alias rm='rm --preserve-root...'


Si le problème vient bien de là, il faudra modifier votre .profile (ou tout autre fichier qui défini vos alias)
--
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
57
Date d'inscription
mercredi 24 juillet 2013
Statut
Membre
Dernière intervention
17 février 2016
14
Oui je pense que sa vient de la, le
alias rm 
donne :
alias rm='rm--preserve-root'
avec le rm collé au --preserve..
le fichier a modifier par défaut (je ne me rapelle pas avoir modifier les alias) et donc:
/etc/skel/.profile

s'il s'agit de celui la le fichier ce présent come cela:
# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
	. "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

Rien a modifier donc ?
Bonjour,

regardez dans votre fichier .bashrc, les alias devraient s'y trouver.
Messages postés
57
Date d'inscription
mercredi 24 juillet 2013
Statut
Membre
Dernière intervention
17 février 2016
14
C'est bon, j'ai modifier l'alias du /home/user/.bashrc tous remarche nickel merci beaucoup !