[Mandrake 10.1] Configurer wifi ratlink 2500

[Résolu/Fermé]
Signaler
-
 CCJ -
Bonjour.
Jutilise mandrake linux 10.1 depuis quelques jour. Jessay de me connecter a ma livebox inventel par le wifi mais en vain.en effet jai crée uneconexion sans fil nommé ra0 par le bias du driver telechargé sur le net. seulement elle n'est pas reconnue pas iwconfig. et je ne peut pas saisir de channel par le biais de linterface utilisateur.
Donc ca ne peut pas fonctionner .

Aidez moi plz

2 réponses

Messages postés
30121
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
23 septembre 2021
7 175
Moi je pense que si tu as une interface ra0 tu es déjà bien avancé. J'aimerais comprendre pourquoi tu dis que iwconfig ne la reconnaît pas. Que se passe-t'il exactement ?

1) Ouvre une console root (uper utilisateur). Charge ton module et vérifie.
modprobe rt2500
lsmod | grep rt2500

Si la deuxième commande ne renvoie rien c'est que le module s'est mal chargé (vérifie que je ne me suis pas trompée dans le nom du module). Il faudrait voir pourquoi il n'est pas chargé :
tail /var/log/messages
dmesg | tail

2) Si le module est bien chargé, active l'interface :
ifconfig ra0 up
iwconfig

Normalement l'interface ra0 doit apparaître. Sinon c'est qu'il manque un alias (cf /etc/modprobe.conf ou un truc dans le genre)

3) A présent il suffit de configurer la carte wifi. A priori tu as une interface graphique dans le centre de controle mandriva pour le faire. Sinon à la main, commence par repérer les différents points d'accès (le tien surtout :p) :
iwlist ra0 scanning

Tu dois voir apparaître ton ESSID sinon c'est que ta carte wifi est mal reconnue ou que le routeur n'émet pas en wifi.
A présent configure la carte wifi en réspectant les minuscules et les majuscules, et précise ta clé wep en accolant les lettres et les numéros. Exemple :
iwconfig ra0 essid "Mon_Essid" key 1234567890ABCDEF

4) Maintenant il suffit de récupérer une IP :
dhclient ra0

Si tu échoues au dhclient c'est probablement que ta carte wifi n'est pas associée au point d'accès wifi (tape iwconfig pour vérifier). Vérifie que tu as bien saisi ton essid, ta clé wep, que le routeur était en mode association etc...

Bonne chance
Salut.
En fait a force de cherche j'ai trouver ce qui foire:
la livebox semble avoir du mal avec le WEP , donc j'ai reconfiguré en wpa par iwpriv au lieu de iwconfig comme suit:

ifconfig ra0 up && iwconfig ra0 channel mon_num_channel && iwconfig ra0 essid mon_essid && iwpriv ra0 set AuthMode=WPAPSK && iwpriv ra0 set EncrypType=TKIP && iwpriv ra0 set WPAPSK="ma_clé"

je remplace par mes données , je tape dans la console.
apre je fais click droit sur la connexion , connecter ra0 et ça roule :D
merci pour votre aide en tt cas!