Recherche valeur minimale, comprise entre deux dates

[Résolu/Fermé]
Signaler
-
 Utilisateur anonyme -
Bonjour,

Je recherche à trouver pour une date donnée, la valeur minimale de la colonne A de la feuille 2 associé à l'intervalle de temps formés par les dates des colonnes E et F (feuille 2) dans lequel est comprit ma date.
J'utilise aussi dans ma formule la colonne A de la feuille 1 juste pour éliminer les années différentes de la date, mais cette colonne n'est peut-être pas utile.

Je recherche la valeur minimale puisque certains intervalle de temps dans la feuille 2 se chevauche.

Voici la formule que j'utilise : =SOMMEPROD((Feuil2!B$2:B$27=$A2)*(Feuil2!C$2:C$27<=$C2)*(Feuil2!D$2:D$27<=$C2)*(MIN(Feuil2!A$2:A$27)))

Excel ne me dit pas que ma formule est fausse mais me renvoi la valeur 0 quel que soit ma date dans le colonne A de la feuille 2.

Fichier : https://www.cjoint.com/?CFcp1geYA2M

J'espère avoir été clair,
En vous remerciant!

3 réponses

Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
Bonjour

en B2 feuille1
=MIN(SI((C2>=Debut)*(C2<=fin);flat))

Debut: plage nommée B2:B27
etc pour Fin et flat

Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule; Excel encadre alors automatiquement la formule par des {}

formule à tirer vers le bas
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
24205
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 octobre 2021
6 939
Bonjour,

ton explication est plutôt incohérente et difficilement compréhensible.
...associé à l'intervalle de temps formés par les dates des colonnes E et F (feuille 2)
On ne voit même pas de référence à E et F dans ta formule (?)

Cependant j'imagine plus une formule du type :
=min(ton_produit_de_matrices)
sans doute avec validation matricielle par Shift+Ctrl+Entrée.

eric

Je vous remercie, cela marche très bien et simplifie le calcul.