Recherche sur date

Résolu/Fermé
Signaler
-
 Utilisateur anonyme -
Bonjour,

J'ai un tableau avec en colonne A (feuille1) une date, colonne B (feuille 1) une autre date; ces deux dates forment un intervalle auquel est associé un nombre (colonne E) sur la même ligne que les deux dates.
J'essaie en feuille 2, pour une date donnée (A2 dans la formule ci-dessous), d'insérer le nombre pour lequel la date rentre dans son intervalle de temps.

Excel semble me renvoyer une somme, je ne parviens pas à trouver l'origine de mon erreur.


Mon fichier : https://www.cjoint.com/?3ExjbuiA0cc

Merci de votre aide!

3 réponses

Messages postés
17676
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
26 novembre 2021
4 843
Salut,

Regarde cette formule

=SOMMEPROD((A5:A17<=A1)*(B5:B17>=A1)*(E5:E17))

si c'est ce que tu cherches et que tu souhaites l'utiliser sur une autre feuille, nomme tes plages exemple A5:A17 nommée col_A, B5:B17 nommée col_B et E5:E17 nommée col_E

ces noms sont à titre indicatif et l'intérêt est d'écourter la formule qui deviendra

=SOMMEPROD((col_A<=A1)*(col_B>=A1)*(col_E))

alors que sur la feuille 2 elle serait
=SOMMEPROD((Feuil1!A5:A17<=A1)*(Feuil1!B5:B17>=A1)*(feuil1!E5:E17))
Messages postés
24221
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 novembre 2021
6 973
Bonjour à tous,

il n'y a pas de feuille 2 ans ton fichier...
eric

Oui effectivement, je me suis trompé.
J'ai trouvé une solution.
Je vous remercie!