Renvoyer du texte dans excel - plage de cellules ? [Résolu/Fermé]

Signaler
Messages postés
41
Date d'inscription
mercredi 4 février 2009
Statut
Membre
Dernière intervention
16 avril 2013
-
Messages postés
25107
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
-
Bonjour,


Je souhaite renvoyer du texte dans la cellule B1 en fonction de ce qu'il y a ecrit dans A1

J'ai crée une feuille dans laquelle j'ai les données

J'y arrive avec
=SI(A1=Feuil1!A1;Feuil1!B1;"")

Je voudrais appliquer la recherche à une plage de cellules. J'essaie

=SI(A1=Feuil1!A1:A6;Feuil1!B1:B6;"")

et la ça ne marche plus - #N/A

Je voudrais une formule dans l'esprit SOMMEPROD mais en renvoyant du texte et non pas un résultat chiffré

J'ai bien parcouru pluqieurs messages sur le sujet mais je n'arrive pas à appliquer les solutions proposées

Quelqu'un a t il une soultion ?

merci d'avance

2 réponses

Messages postés
25107
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 267
Bonjour
Difficile de vous répondre avec ce que vous dites là, et de comprendre comment A1 peut être égal à A1:A6???

Pouvez vous préciser ce que vous mettez en A1, ce que vous avez en Feuil1! A1:A6
etc...
ou alors déposer un modèle avec quelques explications sur:
https://www.cjoint.com/
*en revenant ici placer le lien donné par le site

A vous lire?
crdlmnt
Messages postés
41
Date d'inscription
mercredi 4 février 2009
Statut
Membre
Dernière intervention
16 avril 2013
1
En fait la formule doit aller chercher dans la plage A1:A6, la cellule qui correspond à A1 et du coupa afficher les données correspondantes

je joins le fichier pour plus de clarté



https://www.cjoint.com/?3CslWxMFVMv
Messages postés
2995
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
782
Salut le forum

En B4 =RECHERCHEV($A4;'Adresses-données'!$A$5:$D$16;2;0)
En C4 =RECHERCHEV($A4;'Adresses-données'!$A$5:$D$16;3;0)
En D4 =RECHERCHEV($A4;'Adresses-données'!$A$5:$D$16;3;0)

Formules à recopier vers le bas

Mytå
Messages postés
25107
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 mai 2020
5 267
Bien Myta, bonjour
..... sauf pour la dernière où il faut bien sur transformer le ;3;0) en ;4;0)
crdlmnt