CALC:Format conditionnel dans la Fonction

[Résolu/Fermé]
Signaler
Messages postés
93
Date d'inscription
dimanche 23 mars 2008
Statut
Membre
Dernière intervention
11 octobre 2021
-
Messages postés
54880
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonsoir,

Comment faire , par exemple,les sommes d'un champ sous format conditionnel.

Comment exprimer les conditions dans les fonctions?

Merci.



1 réponse

Messages postés
54880
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 776
Bonjour.

Ce sont bien deux questions distinctes ?

1) "les sommes d'un champ sous format conditionnel" : je suppose que tu voulais dire "la somme de cellules ayant le même format conditionnel" ? Alors il faut repartir des conditions ayant servi à définir ces MFC.

2) "Comment exprimer les conditions dans les fonctions?" en utilisant avec logique et rigueur les fonctions SI, NON, ET, OU.
Pour cela, consulter l'Aide d'Excel et respecter la syntaxe de ces 4 fonctions conditionnelles (qui s'affiche sous forme de bulle quand on commence à les saisir).
https://www.commentcamarche.net/applis-sites/bureautique/1515-utiliser-les-formules-de-base-dans-excel/
https://www.commentcamarche.net/faq/34102-utiliser-plus-de-7-imbrications-si-dans-une-formule
Messages postés
93
Date d'inscription
dimanche 23 mars 2008
Statut
Membre
Dernière intervention
11 octobre 2021
4
Bonjour Raymond,
Les questions ne sont pas distinctes.
Pour un champ, je fais un formatage conditionnel basé sur la couleur de l'arrière-plan
en fonction des valeurs des nombres tapés dans les cellules.
Je pensai simplement faire une sélection conditionnelle juste sur la couleur choisie pour l'arrière-plan. Du genre: =SI(A1:A200=ROUGE..... Je cherchai comment exprimer ce choix
avec la seule couleur comme critère.
Merci.
Cordialement.
Jean.
Messages postés
54880
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 776
Pour cela, il faudrait écrire une macro en utilisant VBA !
Mais là, ça dépasse mes compétences ...