Le fournisseur 'Microsoft.ACE.OLEDB.12.0' n'est pas inscrit [Résolu/Fermé]

Signaler
Messages postés
44
Date d'inscription
vendredi 19 février 2010
Statut
Membre
Dernière intervention
12 mars 2013
-
 Passant -
Bonjour à tous et à toutes,

Avant d'exposer mon problème voici la configuration utilisé :

Windows 8 (x64)
Visual Studio 2010 Ultimate
Microsoft Office 2010 Profesionnel Plus (x86 je pense)
Internet Informations Services 8
Miccrosoft .Net Framework 4.5

Maintenant je peux passer aux problèmes.

Je développe une application ASP.NET que j'aimerai porter sur IIS. Cependant je rencontre énormément de problèmes depuis mon passage sous IIS.
En gros depuis le début de l'application pour la débugger j'utilisais le "Serveur Visual Studio Development" et mon application fonctionne très bien.
Cependant pour etre plus proche de la réalité j'ai décidé d'utiliser a partir de maintenant le "Serveur web IIS Local". Et là les problèmes commencent.

J'ai passé plus de deux heures afin de configurer au mieux mon Windows et IIS pour que le site s'affiche. Après avoir réussi a résoudre ce premier problème je suis passé au suivant.

En effet j'utiliser une base de donnée ACCESS (*.accdb) pour afficher des données sur mon site. Et depuis que je suis passé sous IIS j'ai ce message d'erreur qui s'affiche "Le fournisseur 'Microsoft.ACE.OLEDB.12.0' n'est pas inscrit sur l'ordinateur local."

Alors vous allez me dire qu'il faut installer des "Engine" mais j'ai déjà installer différent composant tel que : http://www.microsoft.com/fr-fr/download/details.aspx?id=23734 ou bien http://www.microsoft.com/fr-fr/download/details.aspx?id=13255 mais rien y fait !

Est ce que parce que mon OS n'est pas pris en charge par ces fichiers ???

Vous allez évoqué le fait qu'il faille passer de la plateforme "Any CPU" à "x86" ou bien l'inverse, je vous arrête tout de suite j'ai déjà essayé :)

Est ce que j'ai loupé une configuration quelque part ???
Aurai je oublié quelque chose ???

Je suis sur le point de craquer et j'en appel à toutes vos connaissances sur ce sujet.

Merci d'avance ^_^

1 réponse

Messages postés
44
Date d'inscription
vendredi 19 février 2010
Statut
Membre
Dernière intervention
12 mars 2013
6
Apres une nouvelle recherche voici ce que j'ai trouvé et qui fonctionne. Etant sur un system 64bit, IIS l'est aussi. Et comme Office est en 32 il faut activer la compatibilité entre le deux comme ceci : (désolé lien en anglais)
https://docs.microsoft.com/en-us/iis/application-frameworks/running-classic-asp-applications-on-iis-7-and-iis-8/using-classic-asp-with-microsoft-access-databases-on-iis

Working with 64-bit Systems

Unfortunately there are no 64-bit ODBC drivers, so on 64-bit systems you will have to run your applications in 32-bit mode. To do so, use the following steps:

- On the taskbar, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
- In the Connections pane, click Application Pools.
- Highlight the application pool for your application, then click Advanced Settings... in the Actions pane.
- In the Advanced Settings dialog, specify True for Enable 32-Bit Applications.
- Click OK to close the Advanced Settings dialog.
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci