Microsoft.ACE.OLEDB.12.0

Fermé
Aloubedi Messages postés 41 Date d'inscription dimanche 1 novembre 2015 Statut Membre Dernière intervention 13 septembre 2018 - 1 nov. 2015 à 13:28
Aloubedi Messages postés 41 Date d'inscription dimanche 1 novembre 2015 Statut Membre Dernière intervention 13 septembre 2018 - 14 nov. 2015 à 16:35
Bonjour,
Lors de la connexion à une source de données MS Access sous Microsoft Visual Basic Express 2010, j'ai été bloqué par le msg suivent: Le fournisseur 'Microsoft.ACE.OLEDB.12.0' n'est pas inscrit sur l'ordinateur local. Merci de m'aider à y remédier SVP!


A voir également:

2 réponses

f894009 Messages postés 16707 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 27 septembre 2022 1 654
3 nov. 2015 à 09:33
Bonjour,

source de données MS Access Quel Access avez-vous ????
1
Aloubedi Messages postés 41 Date d'inscription dimanche 1 novembre 2015 Statut Membre Dernière intervention 13 septembre 2018
5 nov. 2015 à 11:54
Bonjour f894009! J'ai MS Access 2013. désolé pour le retard car j'étais hors zone.
0
f894009 Messages postés 16707 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 27 septembre 2022 1 654 > Aloubedi Messages postés 41 Date d'inscription dimanche 1 novembre 2015 Statut Membre Dernière intervention 13 septembre 2018
5 nov. 2015 à 11:56
Bonjour,

Microsoft.ACE.OLEDB.15.0
0
Aloubedi Messages postés 41 Date d'inscription dimanche 1 novembre 2015 Statut Membre Dernière intervention 13 septembre 2018 > f894009 Messages postés 16707 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 27 septembre 2022
6 nov. 2015 à 23:09
Merci bcp pour la réponse, cependant:
1- Comment avoir Microsoft.ACE.OLEDB.15.0
2- Comment remplacer Microsoft.ACE.OLEDB.12.0 par Microsoft.ACE.OLEDB.15.0 ?
0
f894009 Messages postés 16707 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 27 septembre 2022 1 654 > Aloubedi Messages postés 41 Date d'inscription dimanche 1 novembre 2015 Statut Membre Dernière intervention 13 septembre 2018
7 nov. 2015 à 07:04
Bonjour,

Il me semble que vous avez du code Vb ou il est fait reference a Microsoft.ACE.OLEDB.12.0

il suffit de remplacer le 12 par 15 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
0
Aloubedi Messages postés 41 Date d'inscription dimanche 1 novembre 2015 Statut Membre Dernière intervention 13 septembre 2018 > f894009 Messages postés 16707 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 27 septembre 2022
10 nov. 2015 à 00:15
Bonsoir! encore merci de me suivre. Il m'est tout simplement impossible de remplacer le 12 par le 15 car je ne l'ai pas en option. cependant, dans les Propriétés avancées, j'ai trouvé un 2ème et dernier Provider à savoir Microsoft.Jet.OLEDB.4.0 et ça marche!
0
cs_Le Pivert Messages postés 7822 Date d'inscription jeudi 13 septembre 2007 Statut Contributeur Dernière intervention 16 septembre 2022 716
7 nov. 2015 à 09:00
Bonjour,

J'ai eu ce problème quand je suis passé de XP à W8, avec mes programmes de BDD.

voir ceci:

https://codes-sources.commentcamarche.net/source/view/55175/1329615

je me suis servi de cette ligne de code:

 connex.ConnectionString = "Provider=Microsoft.ACE.OLEDB.12.0;Password=;User ID=Admin;Data Source=" & Cheminsource

0
cs_Le Pivert Messages postés 7822 Date d'inscription jeudi 13 septembre 2007 Statut Contributeur Dernière intervention 16 septembre 2022 716
7 nov. 2015 à 09:09
Maintenant, je suis passé à W10, cela fonctionne toujours!
0
f894009 Messages postés 16707 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 27 septembre 2022 1 654
7 nov. 2015 à 09:09
Bonjour,

Ok si vous avez office 2007, mais lui il a office 2013 et a priori pas office 2007 donc le provider est Microsoft.ACE.OLEDB.15.0
0