Remplacer texte par valeur dans formule "SI"

[Résolu/Fermé]
Signaler
-
 Michael -
Bonjour,

J'effectue une formule avec SI. Un extrait, =SI(A5="AB";"5"SI("A5="DE";"10".....
Mais voilà une fois que je souhaite additionner les résultats de ces formules la somme est égale à 0. Je pense que les valeurs (ici "5" et "10") sont considérés comme des textes et non des valeurs. Quelle appération dois-je effectué pour modifier celà ? (Très simple, je suis sure, mais j'ai tout fait en vain...)

MERCI

3 réponses

Messages postés
24197
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 924
Bonjour,

Si tu écris "5" tu as le caractère 5, si tu écris 5 tu as le chiffre 5
Enlève les " " autour des nombres.
=SI(A5="AB";5;...

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Super, merci
Messages postés
1164
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
1 octobre 2021
156
Salut,
Sur Excel, pour convertir un texte en nombre tapes "=CNUM(A1)" donc ici essaye de mettre ça devant les cases dans la formules :)
Ou alors fais une colonne avec lal iste des autres cases en faisant une suite de la formule Cnum et après prends dans ta formule SI les cases avec Cnum
Bon Courage :)