2 formules dans une meme cellule sur excel

Résolu/Fermé
isolo - 21 sept. 2012 à 10:46
chossette9
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
- 21 sept. 2012 à 11:39
Bonjour,

j'ai 4 colone A B C et D, A est une valeure constante exemple:1 000 000, maintenant mon probléme c'est que je dois remplir soit la colone B ou la colone C et je dois avoir dans la cellule D le resultat suivant:
D=A+B (si j'ai rempli B) sinon D=A-C (si je rempli C et non B).
Alor comment faire pour que dès que je rempli l'une des cellules B ou C que j'ai automatiquement le resultat dans la cellule D.

Merci de m'aider j'ai beau essayer et chercher mais je trouve pas

A voir également:

3 réponses

chossette9
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 310
21 sept. 2012 à 10:50
Bonjour,

en D :

=SI(NON(ESTVIDE(B1));A1+B1;SI(NON(ESTVIDE(C1);A1-C1;""))

Cordialement.
1