2 formules dans une meme cellule sur excel [Résolu/Fermé]

Signaler
-
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
-
Bonjour,

j'ai 4 colone A B C et D, A est une valeure constante exemple:1 000 000, maintenant mon probléme c'est que je dois remplir soit la colone B ou la colone C et je dois avoir dans la cellule D le resultat suivant:
D=A+B (si j'ai rempli B) sinon D=A-C (si je rempli C et non B).
Alor comment faire pour que dès que je rempli l'une des cellules B ou C que j'ai automatiquement le resultat dans la cellule D.

Merci de m'aider j'ai beau essayer et chercher mais je trouve pas

3 réponses

Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 236
Bonjour,

en D :

=SI(NON(ESTVIDE(B1));A1+B1;SI(NON(ESTVIDE(C1);A1-C1;""))

Cordialement.
j'ai tapé la formule mais il me di que : " Vous avez tapez un nombre trop important pour cette fonction".
voici ma formule: =SI(NON(ESTVIDE(D4));C4-D4;SI(NON(ESTVIDE(E4);C4+D4;"")))

dans ce cas si, C4 est la constante, maintenant le resultat de F4 dépant de D4 et C4.
si je rempli D4 je dois avoir F4=C4-D4 et F4=C4+E4 dans le cas contraire.
Messages postés
16173
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 juillet 2020
2 998
il y a une parenthèse qui manque

=SI(NON(ESTVIDE(B1));A1+B1;SI(NON(ESTVIDE(C1));A1-C1;""))
Messages postés
4237
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 236
Exact, oublié une parenthèse ^^
Merci Beaucoup, ça marche
tu es un ange