Passer en super utilisateur sous debian(sudo) [Résolu/Fermé]

Signaler
Messages postés
49
Date d'inscription
mercredi 6 août 2008
Statut
Membre
Dernière intervention
3 septembre 2012
-
Messages postés
2080
Date d'inscription
jeudi 16 septembre 2004
Statut
Membre
Dernière intervention
4 novembre 2019
-
Bonjour,

je suis sous ubuntu et fedora depuis un moment et maintenant je commence à m'interesser a DEBIAN et son interface KDE alors j'ai decidé de le técharger et l'installer , j'ai télécharger les 8 DVD disponible sur le site (vu que je ne dispose pas d'une bonne connexion internet), je l'ai installer au debut avec une interface graphique (GNOME par defaut), et maintenant je viens de le réinstaller en mode console seulement, et dans les deux cas j'ai le meme probleme, pendant l'installation, je spécifie un mot de passe pour le root (disons rootPass), et un utilisateur "moi" et son mot de passe "moiPass", je peux me loguer en tant que user (que ça soit en mode console ou en interface graphique), mais dès lors que j'essaie de passer en Super utilisateur j'ai le message :
moi not in the sudoers fils . this incident will be reported , alors impossible de passer en super utilisateur, j'ai lu quelque part qu'il faut modifier un certain fichier "sudoers" mais pour cela il faut passer root, chose que j'y arrive tjrs pas, SVP je galère ça fait dèjà 15 jours maintenant je l'ai réinstaller plusieurs fois sans succès



9 réponses


Lance su, et non su <commande>
13
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63753 internautes nous ont dit merci ce mois-ci

Messages postés
2080
Date d'inscription
jeudi 16 septembre 2004
Statut
Membre
Dernière intervention
4 novembre 2019
229
Une fois que tu as un accès root, tu peux ajouter l'utilisateur voulu au groupe sudo :
su
adduser moi sudo
exit

Une fois (dé)relogger tu pourras utiliser la commande sudo.
Messages postés
49
Date d'inscription
mercredi 6 août 2008
Statut
Membre
Dernière intervention
3 septembre 2012
3
que ça soit avec

su -

ou

su

je reçoit toujours le même message d'erreur.
Messages postés
98
Date d'inscription
samedi 24 janvier 2009
Statut
Membre
Dernière intervention
13 septembre 2016
2
Sache une chose mon ami, c'est que pour des raisons de sécurité Debian n'accepte pas directement les accès root mais plutôt il faut te connecter avec un utilisateur puis passer en root comme l'a spécifié saacha.

Cdlt

Salut,

Je crois que Debian est super sécurisé sur les comptes. Toi simple USER, tu n'es pas dans le groupe Sudoers car tu n'as pas les permissions Root.

Si tu veux avoir accès au compte Root, utilise la commande :

su

Ou force avec :

su -

Bonne chance.
Messages postés
49
Date d'inscription
mercredi 6 août 2008
Statut
Membre
Dernière intervention
3 septembre 2012
3
Merci beaucoup, je viens de passer en root :), Problème resolu, j'ai encore une petite question, j'ai télécharger les 8 DVD de DEBIAN afin de ne plus avoir recours à Internet quand j'ai besoin d'installer une application, mais maintenant quand j'ai lancé l'installation de KDE "apt-get install kde" il commence à télécharger les paquets à partir d'internet et moi qui s'attendait à ce qu'il me demande d'inserer l'un de mes 8 DVD, comment faire pour installer KDE à partir des DVD ? sinon merci beaucoup
Messages postés
35009
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
5 juillet 2020
5 248
Salut,

Dans "/etc/apt/sources.list" il ne faut laisser que tes DVD's comme source ;-)

Salut Zipe ;-),

Apt-get fonctionne en local ?

Je ne sais pas comment sont fait le DVDs Debian, mais on ne peut pas utiliser dpkg ?
Messages postés
35009
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
5 juillet 2020
5 248
Salut,

Apt-get fonctionne en local ?
Ben apt-get dépend du contenu du sources.list. Tu peux même lui indiquer un répertoire de ton disque si tu veux.
Utilisateur anonyme
ça marche ;-)
Messages postés
49
Date d'inscription
mercredi 6 août 2008
Statut
Membre
Dernière intervention
3 septembre 2012
3
voila je suis sous mon Debian actuellement, KDE vient d'etre installé, c pa ce que j'attendais (en realité j'avais vu un KDE à l'école plus beau que ça ^^, je vais creuser un peu lol), pour le fichier sources.list, voila ce que j'ai dedan :

#

# deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42]/ squeeze contrib main

deb cdrom:[Debian GNU/Linux 6.0.4 _Squeeze_ - Official amd64 DVD Binary-1 20120128-13:42]/ squeeze contrib main

deb http://debian.univ-reims.fr/debian/ squeeze main
deb-src http://debian.univ-reims.fr/debian/ squeeze main

deb https://www.debian.org/security/ squeeze/updates main contrib
deb-src https://www.debian.org/security/ squeeze/updates main contrib

# squeeze-updates, previously known as 'volatile'
deb http://debian.univ-reims.fr/debian/ squeeze-updates main contrib
deb-src http://debian.univ-reims.fr/debian/ squeeze-updates main contrib

est ce que ça veut dire que ça ne prend en compte que le 1er DVD ?? (au faite je viens de lancer apt-get install rpm et il m'a demander d'inserer le premier DVD, ça me rassure, mais je veux qu'il le fasse pour les 8 DVD c possible ?
Messages postés
35009
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
5 juillet 2020
5 248
Normalement oui. Mais dans le doute tu peux commenter les sources sur le Net..

@Zipe,

On utilise les preferences.list ou on touche direct au sources.list ?
Messages postés
365
Date d'inscription
dimanche 1 avril 2012
Statut
Membre
Dernière intervention
29 septembre 2013
23
bonjour, perso j'arrive aux meilleurs résultats en modifiant le fichier source.list - Aussi je pense que la connection internet est fortement conseillée pour une debian voire indispensable ;-)
Pour déclarer les 8 DVD a Debian (ou sources.list), il faut le faire avec la commande spécifiquement conçue pour :

#apt-cdrom add

puis a chaque fois il te demande d'insérer un CD pour analyser son index. tu le fait pour les 7 DVD restants. comme tu a tout les 8 DVD déclarer sur ton sources.list

Bonne chance.