Formule calcul IMC excel 2010 [Résolu/Fermé]

Signaler
Messages postés
23
Date d'inscription
lundi 5 décembre 2011
Statut
Membre
Dernière intervention
25 mai 2012
-
Messages postés
23
Date d'inscription
lundi 5 décembre 2011
Statut
Membre
Dernière intervention
25 mai 2012
-
Bonjour à tous,

Je cherche actuellement à rentrer la bonne formule (sur excel pour mac 2010) qui me permettrait d'avoir les différents indices de masse corporelle en fonction des valeurs correspondantes:

Si la valeur de la cellule H5 < 18,5, alors "maigreur"
Si la valeur de la cellule H5 est comprise entre 18,5 et 24,9, alors "normale"
Si la valeur de la cellule H5 est comprise entre 25 et 29,9, alors "surpoids"
Si la valeur de la cellule H5 est comprise entre 30 et 34,9 , alors "obésité modérée"
Si la valeur de la cellule H5 est comprise entre 35 et 39,9, alors "obésité sévère"
Et enfin, si la valeur de la cellule H5 est supérieure à 40, alors "obésité massive"

Malgré plusieurs tentatives avec différentes fonctions (SI, ET,...), je n'arrive pas à retranscrire cette formule...

Si l'un d'entre vous était capable de m'aider, je lui en serait très reconnaissant, cela me rendrait un fier service !

Merci
A voir également:

6 réponses

Messages postés
23887
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2021
6 659
Re,

une autre formule peut-être plus simple à faire évoluer :
=CHOISIR(EQUIV(H5;{0;18.5;25;30;35;40};1);"maigreur";"normale";"surpoids";"obésité modérée";"obésité sévère";"obésité massive")

eric
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
1900
Date d'inscription
jeudi 1 décembre 2011
Statut
Membre
Dernière intervention
16 février 2012
613
=SI(A1<18,5;"maigreur";SI(A1<24,9;"normale";SI(A1<29,9;"surpoids";SI(A1<34,9;"obésité modérée";SI(A1<39,9;"obésité sévère";SI(A1>39,9;"Obésite massive"))))))

la si tu n'y arrive pas je crois qu'on ne peut plus rien pour toi il y a juste un copier coller à faire.
Messages postés
23
Date d'inscription
lundi 5 décembre 2011
Statut
Membre
Dernière intervention
25 mai 2012
2
C'est bon c'est réglé ! :)

Un grand merci à tous les deux, vos deux méthodes fonctionnent parfaitement !
Messages postés
1900
Date d'inscription
jeudi 1 décembre 2011
Statut
Membre
Dernière intervention
16 février 2012
613
=SI(A1<18,5;"maigreur";SI(A1<24,9;"normale";SI(A1<29,9;"surpoids")))

je te laisse continuer ;)
Messages postés
23
Date d'inscription
lundi 5 décembre 2011
Statut
Membre
Dernière intervention
25 mai 2012
2
Merci pour ta réponse si rapide :)

Le problème est qu'en faisant cette formule, cela me marque "la valeur à entrer doit être une décimale supérieure à 18"

Je ne comprends pas pourquoi mais si tu as une idée du problème, n'hésite pas merci !
Messages postés
23887
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 février 2021
6 659
Bonjour,

Ton séparateur décimal est-il bien la virgule ?
Sinon remplace 18,8 par 18.5

eric
Messages postés
23
Date d'inscription
lundi 5 décembre 2011
Statut
Membre
Dernière intervention
25 mai 2012
2
Oui eric, mon séparateur décimal est bien la virgule, le problème est donc ailleurs...

Quelqu'un pourrait-il me taper la formule entière très précisément? Je dois être nul mais avec la formule complète, je devrais m'en sortir (enfin j'espère!).

Merci d'avance à celui ou celle qui se dévouera pour ma noble cause ;)