Calcul du salaire sur Excel avec la F "Si(Et( [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
dimanche 11 février 2007
Statut
Membre
Dernière intervention
18 mars 2012
-
Messages postés
11
Date d'inscription
dimanche 11 février 2007
Statut
Membre
Dernière intervention
18 mars 2012
-
Bonjour,

J'essai de dresser un tableau sur excel 2007, qui explique le calcul des salaires.
Je me suis trouvé devant deux problémes, le premier se résume en :

( les donnés )

1/ Prime d'anciennété en année :

]2;5] = 5 %
]5;15] = 10%
]12;20] = 15%
20 ans et plus =20%

2/ Le calcul de des impots :

Salaire Brut | Somme à déduire
0-1500 | 0
1501-2000 | 195
2001-3000 | 355
3001-5000 | 775
5001 et plus | 1225


Si c'est possible d'avoir une explication sur la fonction à écrire, ça serait sympa.
Bonne fin de semaine.

A voir également:

2 réponses

Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 195
Bonjour
=SI(A1="";"";SI(A1<2;0:SI(A1<=5;0,02;si(A1<=15;0,10;si(A1<=20;0,15;0,20)))))

mais que veux tu dire avec cette contradiction 20] et 20ans et plus ?

emploie le même systeme pour tes imp^ts

SI(A1="";"";SI(A1<=1500;0;SI(A1<=2000.... etc

mais expliques nous: que ce passe t'il entre 1500 et 1501 par exemple (je sais ce que tu vas dire mais on est pas fiscalistes mais bidouilleurs: il y a donc un trou)
Michel
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
11
Date d'inscription
dimanche 11 février 2007
Statut
Membre
Dernière intervention
18 mars 2012

pour te répondre sur 20], je vais t'expliquer par un petit exemple :

André est fonctionnaire sur une société X depuis 19 ans; donc sa prime d'ancienneté sera de 15 % , l'ancienneté d' André est comprise entre ]12;20]
autrement dit : 12=< ancienneté André < 20
l'ancienneté d 'André doit être supérieur ou égale à 12, et strictement inférieure à 20 pour lui appliquer le taux 15%.

Pour les impots, c'est le même constat, à la place d'utiliser les [ : [ j ai mis des tranches .
si le salaire est compris entre 0 et 1500,00 Euro , la déduction est 0; si le salaire est compris entre 1501 et 2000 Euro, la déduction est de 195 euro.
Messages postés
16491
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 juillet 2021
3 195
ok, les histoires d'intervalles ouverts et fermés, c'est vieux dans ma t^te ; tu n'as qu'à modifier les < = >

Tu vois, j'étais sûr de ta réponse sur les impôts.... maintenant tu fais ce que tu veux avec ces limites d'intervalles foireuses....: si égal ou inférieur à 1500 pas la peine de marquer 1501!!! :-((

Surtout ne dis pas pas merci pour le temps passé à essayer de t'aider...
Messages postés
11
Date d'inscription
dimanche 11 février 2007
Statut
Membre
Dernière intervention
18 mars 2012

oui, ça marche .. !

un Merci, ça s'impose :)