[EXCEL] possible de faire 2 recherchev ?

Fermé
boeno - 23 août 2006 à 10:44
 guilders - 26 oct. 2007 à 15:41
Bonjour,
en faite j'ai écris ca :

=SI(ESTERREUR(RECHERCHEV($A5;[nomenfants.xls]Feuil1!$B4:$B4;0;FAUX)=$A5);DATE([nomenfants.xls]Feuil1!$F4;[nomenfants.xls]Feuil1!$G4;[nomenfants.xls]Feuil1!$H4);"")

j'aimerai savoir si c'est possible de mettre deux recherchev dans le SI pour verifier que le résultat du premier est correct ...

merci d'avance
boeno

9 réponses

gbinforme Messages postés 14946 Date d'inscription lundi 18 octobre 2004 Statut Contributeur Dernière intervention 24 juin 2020 4 688
25 août 2006 à 17:30
bonjour

et bien en faite j'aimerai juste savoir si on peut faire deux recherche à la suite

J'ai bien compris que tu veux absolument utiliser recherchev,
même si cela ne sert apparemment à rien, comme j'ai dit.

Alors tu peux en empiler plusieurs, il suffit de "concatener" :

= RECHERCHEV($A5;[nomenfants.xls]Feuil1!$B4:$B40;0;FAUX)&RECHERCHEV($A5;[nomenfants.xls]Feuil2!$B4:$B40;0;FAUX)&RECHERCHEV($A5;[nomenfants.xls]Feuil3!$B4:$B40;0;FAUX)(

c'est le caractère "&" qui concatène les résultats.

Tu peux aussi bien sûr, auparavent, contrôler le résultat : SI(ESTERREUR(...
et tu nous informes de la formule obtenue pour que j'arrive à comprendre le motif.

Bon courage
2