Test logique avec 2 conditions [Résolu/Fermé]

Signaler
Messages postés
49
Date d'inscription
mardi 6 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2014
-
Messages postés
49
Date d'inscription
mardi 6 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2014
-
Bonjour,

sous excel, je veux faire un test logique (condition si)

si (a= champ; ou= "")=""

si (a # champ; ou# "")= 1

merci pour vos reponses

A voir également:

5 réponses

Messages postés
538
Date d'inscription
vendredi 20 mai 2011
Statut
Membre
Dernière intervention
8 janvier 2018
96
Bonjour Raveno39,


=SI(OU(A1=5;A1="");"";0)
=SI(OU(A1<>5;A1<>"");1;0)
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
538
Date d'inscription
vendredi 20 mai 2011
Statut
Membre
Dernière intervention
8 janvier 2018
96
J'arrive à obtenir le même résultat lorsque je mets en formule dans une colonne

=SI(OU(TaCelluleDeLaLigne="rouge";TaCelluleDeLaLigne="");1;2)


et mettre cette formule sur chaque ligne en étirant la formule.

Ainsi tu auras sur les lignes

=SI(OU(A1="rouge";A1="");1;2) en ligne 1
=SI(OU(A2="rouge";A2="");1;2) en ligne 2
=SI(OU(A3="rouge";A3="");1;2) en ligne 3
etc...
Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 429
J'ajoute pour Raveno39 que:

- si ton test concerne des valeurs, tu ne dois pas mettre les guillemets (voir le prmier post d'Heremion ou le test indique A1=5 )
- si ton test concerne des chaines de caractères, tu dois les mettre : A1="rouge" et pas A1=rouge
Messages postés
49
Date d'inscription
mardi 6 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2014
15
je vous ai mis en image ce que je voulais car j'ai essayé les formules qui ont ete mises, elles ne marchent pas si je remplace les chiffres par des noms

[url=https://www.casimages.com/i/110922020859580453.jpg.html][img]http://nsa27.casimages.com/img/2011/09/22/mini_110922020859580453.jpg[/img][/url]

merci
Messages postés
49
Date d'inscription
mardi 6 septembre 2011
Statut
Membre
Dernière intervention
11 septembre 2014
15
ok ça marche
merci
Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 429
Il faut utiliser l'opérateur ET et la formule SI combinés. pour le reste, ta question donne déjà sa propre réponse.