Excel - Affecter valeur vide à une cellule [Résolu/Fermé]

Signaler
-
 ludogalere -
Bonjour à tous.

Je rencontre une difficulté pour le traitement de données au niveau professionnel, voici mon problème:

Je souhaite effectuer des calculs de moyenne, d'écart-type et de mode sur une plage de cellules. Ces cellules vont chercher leur valeur ailleurs. Exemple:

E10=DECALER($L$33;11*$A10;0)

Le problème est que lorsque la cellule source est vide, E10=0. Et donc cette valeur 0 est prise en compte dans mes calculs de moyenne, mode, écart-type.

Ce que j'aimerais, c'est attribuer une valeur VIDE à E10, lorsque sa cellule source est vide en évitant de passer par du code VBA long et fastidieux.

Merci de votre aide!

2 réponses

Messages postés
714
Date d'inscription
lundi 16 mai 2011
Statut
Membre
Dernière intervention
1 décembre 2011
35
Salut,

tu as essayé:

Outils => Option => Décocher "Valeur zéro" ?
Salut Ctesias.

Ca pourrait marcher mais le problème c'est que parfois, les valeurs de mes cellules sont volontairement de 0. Comme un élève qui aurait obtenu 0 à son devoir, ce 0 doit être compté dans sa moyenne.
Messages postés
714
Date d'inscription
lundi 16 mai 2011
Statut
Membre
Dernière intervention
1 décembre 2011
35
Le probleme, c'ets que excel ne fera pas la différence entre un 0 voulu, et un 0 non voulu... Personnellement, je ne pense pas avoir de solution la... Désolé.
Je sais bien, c'est pour ça que je souhaite que la cellule soit vide, et non pas =0
Merci pour tes efforts
Messages postés
25206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 juillet 2020
5 385
Bonjour
essayez en E10:
=SI(DECALER($L$33;11*$A10;0);"";DECALER($L$33;11*$A10;0))
ça ne colle pas avec tous les codes , car dans certaines formules,"" renvoie valeur, mais par exemple (sur excel 2007) MOYENNE fonctionne
Alors ça vaut peut être la peine d'essayer avec vos formules

crdlmnt
Bonjour Vaucluse.

Hélas ça ne marche pas et ça me renvoie effectivement #VALEUR.

Merci de ton aide
Messages postés
2344
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
30 juillet 2020
861
Bonjour,
À tout hasard essayez une formulation voisine:
=SI(ESTVIDE(DECALER($L$33;11*$A10;0));"";DECALER($L$33;11*$A10;0))
Tontong, ca marche pour le calcul de mode et de moyenne, mais pas pour la formule suivante:

L10==E10*Pondération!$C$17+F10*Pondération!$D$17+G10*Pondération!$E$17+H10*Pondération!$F$17+I10*Pondération!$G$17+J10*Pondération!$H$17

Aurais-tu une idée? J'ai l'impression qu'on est pas loin!
Messages postés
25206
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
31 juillet 2020
5 385
RE
=SI(E10="";0;E10*pondération!$C$17)+SI(F10="";0;F10*pondération!$D$D17)+ etc....
crdlmnt
Ca marche!!

Merci Vaucluse. Et merci aux autres d'avoir pris le temps de m'aider aussi.