RechercheV plusieurs valeurs sous Excel [Résolu/Fermé]

Signaler
Messages postés
15
Date d'inscription
vendredi 6 mai 2011
Statut
Membre
Dernière intervention
17 janvier 2013
-
Messages postés
1
Date d'inscription
dimanche 3 février 2019
Statut
Membre
Dernière intervention
3 février 2019
-
Bonjour a tous,

Je suis au bord de la crise sous Excel!
Je n'arrive pas à faire une recherche V sur plusieurs valeurs.
Ma table de donnée est (exemple) :

Feuille 1

-----A----B
1---521---Ok
2---522---PB
3---569---PV
4---569---PJ
5---569---PK

Feuille 2

-----A--------B
1
2
3
4
5
En A1 je mets ma valeur recherche
En B1 je mets la fonction :=RECHERCHEV($A$1;Feuille1!A1:B5;3)

Si je fais une recherché V sur A1= 521 c'est ok il me sort en B1 la valeur Ok
Si je fais une recherche V sur A1= 569 il me sort en B1 seulement la valeur PV alors que je voudrais PV et PJ et PK....

Qui peut m'aider ???

Merci d'avance



A voir également:

3 réponses

Messages postés
16369
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 janvier 2021
3 115
Bonsoir,

Tant qu'on peut se passer tranquillement de VBA....

https://mon-partage.fr/f/WKLLQFnd/
78
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
16369
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 janvier 2021
3 115 > Pop
Bonjour,

Puis-je me permettre de vous demander la réactivation du lien j'ai exactement le même problème ?

Cordialement
Messages postés
16369
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 janvier 2021
3 115 > LauraG
Voir post 173
Bonjour Michel_m,

Merci pour votre aide précieuse.
Messages postés
1
Date d'inscription
dimanche 3 février 2019
Statut
Membre
Dernière intervention
3 février 2019

Bonjour Michel_m,
Je vous remercie pour les solutions proposées et j'ai retenue la formule matricielle pour mon tableau.
Je souhaite toutefois réinitialiser la liste à chaque ligne de mon tableau.

Je vous remercie par avance de votre aide

www.grosfichiers.com/BOEnEfBw9FgSw
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 289
Bonjour,

les fonction de recherche ne permettent de retourner qu'une seule occurrence. Si vous souhaitez plusieurs occurrences, vous pouvez regarder de ce côté.

Cordialement.
Bonjour,

J'ai aussi le même problème est-il possible de réuploader le fichier SVP ?
merci beaucoup
Messages postés
16369
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 janvier 2021
3 115
Messages postés
7
Date d'inscription
dimanche 21 avril 2013
Statut
Membre
Dernière intervention
8 janvier 2015

merci Michel,

bien à toi!
Il dure pas long le lien :(
C'est possible de le remettre..?
Messages postés
16369
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
21 janvier 2021
3 115 > ricohn
Inutile d'être de mauvaise foi, je vous aurais remercié...
Merci pour le lien !