RechercheV plusieurs valeurs sous Excel

Résolu/Fermé
thezipper Messages postés 15 Date d'inscription vendredi 6 mai 2011 Statut Membre Dernière intervention 17 janvier 2013 - 8 juin 2011 à 17:28
Geoblog06 Messages postés 1 Date d'inscription dimanche 3 février 2019 Statut Membre Dernière intervention 3 février 2019 - 3 févr. 2019 à 15:54
Bonjour a tous,

Je suis au bord de la crise sous Excel!
Je n'arrive pas à faire une recherche V sur plusieurs valeurs.
Ma table de donnée est (exemple) :

Feuille 1

-----A----B
1---521---Ok
2---522---PB
3---569---PV
4---569---PJ
5---569---PK

Feuille 2

-----A--------B
1
2
3
4
5
En A1 je mets ma valeur recherche
En B1 je mets la fonction :=RECHERCHEV($A$1;Feuille1!A1:B5;3)

Si je fais une recherché V sur A1= 521 c'est ok il me sort en B1 la valeur Ok
Si je fais une recherche V sur A1= 569 il me sort en B1 seulement la valeur PV alors que je voudrais PV et PJ et PK....

Qui peut m'aider ???

Merci d'avance



A voir également:

3 réponses

michel_m Messages postés 16603 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 16 décembre 2023 3 304
Modifié le 12 déc. 2018 à 22:09
Bonsoir,

Tant qu'on peut se passer tranquillement de VBA....

https://mon-partage.fr/f/WKLLQFnd/
78
thezipper Messages postés 15 Date d'inscription vendredi 6 mai 2011 Statut Membre Dernière intervention 17 janvier 2013 96
9 juin 2011 à 16:59
Un seul mot a dire : wwwhhaaaooouu. c'est puissant ! et je rajouterai meme un grand merci a vous.

j'ai bien resolu mon probleme :-)))

Merciiiii
68
J'ai eu quelques difficultés à comprendre au début comment transposer tout ça à mon cas, mais je devrais m'en sortir.

Merci beaucoup pour l'aide apportée ! Et pour ta réactivité !
70