WampServer ne veut pas se conecter

Bonjour a tous !

J'ai installer WampServer sur mon Windows Seven, tout s'est bien déroulé, mais lorsque l'icone de Wamp s'affiche près de l'horloge, l'icone reste orange. Et quand je clique sur Localhost, la page de WampServer ne s'affiche pas !
Comment faire ???

16 réponses

Résumé de la discussion

Problème rencontré avec WampServer sur Windows 7, l'icône près de l'horloge reste orange et la page Localhost ne s'affiche pas, ce qui empêche le lancement du serveur local. Plusieurs réponses évoquent un service Apache soit arrêté soit non installé, préconisant de démarrer ou d'installer le service via le menu d'icône, ou de le démarrer avec Start/Resume. D'autres analyses suggèrent de vérifier l'utilisation du port 80 par des applications comme Skype, Dreamweaver ou EasyPHP et d'assurer qu'aucun autre programme n'occupe ce port. En cas de persistance, des solutions complémentaires apparaissent, notamment la vérification de la présence du fichier wampserver.conf et le redémarrage des services, ou bien l'examen des ports via des outils externes.

Bobot (l’IA à votre service)
  1. Bonjour à toute l'équipe Commentçamarche;

    Monsieur la cause de ce problème est: Apache Service soit arrêter ou bien n'est pas Installé.

    1- Si le service est suspendu:
    Clique gauche sur l'icône orange => Apache => Service => Start/Resume Service

    2- Si le service n'est pas installé:
    Clique gauche sur l'icône orange => Apache => Service => Install Service
    8
    1. quand j'installe le service d'apache un message s'affiche dans la cmd "cannot install the apache service , please stop this application and try again "
      0
    2. ça a marché pour moi !!!
      merci bcp c tres gentil :)
      0
  2. Tout d'abord, il faut savoir qui utilise le port 80 (Skype (-> Est-ce qu'il se lance au démarrage ?), dreamviewer, EasyPHP) et savoir si un logiciel semblable a Wamp n'est pas en service (EasyPHP, LAMP, MAMP, etc..).

    Si tu as vérifier le tout et que le problème persiste, je ne vois pas trop comment t'aider :/
    2
    1. j'ai vérifié et le port 80 est libre, mais toujours pareil..
      0
    2. Effectivement moi c'était Skype...
      Merci pour l'info !
      0
    3. merci ! pour moi c'était skype également !
      0
    4. Merciiii pour ta réponse elle m'a aidé énormément, c'était skype en fait!!
      0
    5. j'ai tout essaayé mais ca ne marche il m'affcihe ça lors du lancement de locahost HTTP Error 404. The requested resource is not found.
      0
  3. Bonjour,

    Quelle version de WampServer s'il vous plaît ?

    Cordialement.
    1
    1. Merci de me répondre !
      J'utilise WampServer 2.1 sous W7
      0
  4. Pas de soucis ^^

    Vérifiez que le fichier "wampserver.conf" soit bien présent dans le répertoire C:\wamp\bin\apache\apache2.2.11 (enfin du moins, ce chemin est celui par défaut)

    Si ce n'est pas le cas, créez le en mode texte et ajoutez les lignes suivantes :

    <?php
    $apacheConf['apacheExeDir'] = 'bin';
    $apacheConf['apacheConfDir'] = 'conf';
    $apacheConf['apacheExeFile'] = 'httpd.exe';
    $apacheConf['apacheConfFile'] = 'httpd.conf';
    $apacheConf['apacheServiceInstallParams'] = '-n wampapache -k install';
    $apacheConf['apacheServiceRemoveParams'] = '-n wampapache -k uninstall';
    ?>

    Après avoir sauvegardé le fichier, redémarrez les différents services (cliquez sur l'icône de Wampserver dans la barre des tâches et choisissez "Redémarrer les services").

    Cordialement.
    1
    1. J'ai vérifier et en effet je possède bien le fichier en question "wampserver.conf", donc le problème ne vient pas de là.. Tu n'aurais pas une autre idée ?
      1
      1. Regardes dans tes fichiers PHP et APACHE (Ceux que tu vois lorsque tu fais un clique gauche sur l'icône WampServer dans la barre des tâches.) et ouvres les fichiers 'PHP error log' et 'Apache error log'

        Dis moi ce qu'il y a de marqué. S'il te mettent un message du genre qu'ils n'existent pas, cela voudra dire qu'il n'y a pas d'erreur, il faudra essayer de réinstaller.
        1
        1. Oui en effet ils me disent, la page n'existe pas, voulez vous la créer ? (en m'ouvrant le Bloc Note).
          P.S.: J'ai déja penser que c'était un probleme d'installation ou quoi, et du coup je l'ai déjà désinstaller puis ré-installer..
          0
        2. Avez vous EasyPhp, ou un autre logiciel tel que WampServer sur votre ordinateur ? même inactif
          0
        3. Bonjour Deathmann, non je n'ai que WampServer dans ce genre de logiciel
          0
      2. Vous utiliser le serveur IIS de Microsoft, si oui changer le port dans le httpd.conf mettez par exemple un 8080 et ça vas marcher

        signature
        boumardass nal 9jmoran di
        1
        1. En effet jutilise IIS mais comment changer le port ?? je ne sais pas ou aller
          0
      3. Exact, tes ports doivent être disponibles.
        1
        1. Oui mais comment voir si le port 80 est déja utilisé ou non ???
          1
          1. Tu vas sur le site

            https://www.grc.com/x/ne.dll?bh0bkyd2

            - Tu cliques sur 'proceed'
            - Dans le tableau 'ShieldsUP!! Services' en 2 ème case tu cliques sur 'Commons Ports'
            - Tu laisses analyser et deux secondes après une fois le 1er terminé tu cliques sur la 3ème case à coté de 'commons ports' c'est 'all services ports'
            - Si tu as 'Passed' dans chacune des analyses c'est que rien n'est ouvert normalement et a la 2nde si tout ton tableau est remplit de case verte c'est bon (il y a la légende en haut).

            Cordialement.
            1
            1. Oui je lai fait et apparament tout est bon..
              0
            2. C'est bizarre. tu as essayé de lancer PhpMyAdmin, Localhost, accéder à ton répertoire www... ?
              0
            3. (suite)
              .. un message d'erreur :

              Erreur de serveur dans l'application "DEFAULT WEB SITE"
              Résumé de l'erreur
              Erreur HTTP 404.0 - Not Found
              La ressource que vous recherchez a été supprimée, a été renommée ou est provisoirement indisponible.
              0
            4. Avez vous déplacés vos fichiers ? aprés l'installation, il ne faut pas modifier le répertoire de destination. Les pages Web doivent se trouver dans le répertoire www.
              0
            5. Non je n'ai rien déplacer justement j'ai bien mon répertoire www. et j'ai bien suivi la procédure d'installation.
              0
          2. Ta essayé de le désinstallé & de le rinstallé voir si ses pas un problème du au moment de l'installation?
            1
            1. Il l'avait déjà fait.
              0
            2. Merci a tout ceux qui ont répondu, mais en effet le problème a pérsisté donc j'ai abandonné WAMP.. merci tout de meme
              0
            3. Essaye un logiciel idem.
              0
            4. Ces parceque tu as Windows 7 que ça ne marche pas
              moi aussi j'ai essayé Appserve mais ça ne marche pas sur Windows 7
              0
          3. tu dois quitter Skype et pas de déconnecter de Skype ou de changer le num de port pet être déjà réservé
            0
            1. petit UP sont problème je l'ai eu () c'est un truc à la con le problème c'est que je ne me souvient plus de se que c'est ...Oo en tous cas se n'est pas un problème de ports ou autres (même si en effet skype utilise le même que Wamp) donc déconnecter skype avant..
              0
              1. salut
                Je ne sais pas si je viens tard mais j'ai eu le meme problème y'a peu de temps et cela état du à la configuration du proxy, si tu dispose d'un proxy pour te connecter à internet alors tu devrait le desactivé pour les sites locaux. Si ca peut aider.
                0